Normal Tangent Element "Not Consistent" Error

  • 186 Views
  • Last Post 2 weeks ago
  • Topic Is Solved
vganore posted this 05 October 2017

What is the cause of the following ANSYS Mechanical error?

“The normal of target element 19817570 is not consistent with the normal of target element 19817571 in real set 171. Please use the ENORM command to correct it.”

Vishal Ganore, ansys.com/student

pgl posted this 2 weeks ago

The most likely cause of this error is having adjacent contact elements with different normal directions.

The error message is from the MAPDL solver, but in Mechanical a better remedy is usually to repair the underlying geometry rather than using ENORM to flip the element normal directions.

If it not clear which contact pair is causing this error, insert Contact Tool under the Connections branch. In the Initial Information Worksheet, the real constant set for each contact pair is identified. Surface bodies (meshed with shell elements) have a designated "Top" surface which determines the orientation of the body. When selecting a face, with the default graphics settings, the "Top" surface is highlighted in green. You need to ensure that the top surface designation is consistent for all faces in all contacts. If the faces are not consistent, you can either flip the faces using DesignModeler or Spaceclaim, or divide the contact pairs into smaller pairs that have a consistent direction (note: over-constraint might then be an issue with MPC contact). For solid bodies, this behavior can be caused if the contact and/or target side was defeatured at the mesh level. A local mesh size control can help retain features close to the contact. Limiting the scope of the contact and target sides might also help. The tolerance slider can be used to tighten the tolerance of the automatic contact detection. To create contacts with a tighter tolerance, you need to delete the old contact pair and right click on the Connection Group - > "Create Automatic Connections". Finally, if mesh size is not an issue, you can try turning off mesh defeaturing, decreasing the defeaturing tolerance, or using a smaller Min Size with the Advanced Size Function.

Close