Workbench 18.2 Fatal error-Framework error

  • 513 Views
  • Last Post 6 days ago
panther_91 posted this 3 weeks ago

Hello!

I got the following problem, when I try to open the workbench : "Framework error caught:

Fatal error:The view "GraphScene" has not been registered", as you can see on the attached picture.

I repeated the installation and tried on 2 computers, but got the same result.

Could anybody help me to solve this?

Thanks in advance!

Attached Files

  • Liked by
  • designer9595
  • IngAEV
Order By: Standard | Newest | Votes
designer9595 posted this 3 weeks ago

Hi 

I've same problem.I have student version 18.2 but ı can't solved this problem.Can you help me ?

Thank you

pgl posted this 2 weeks ago

OK. After looking around on the web I found that general OS "error" site also had a few people with this problem. I was surprised to find this, but thought I'd share to see if this helps you: 

One of the posters states that "this error is usually caused by misconfigured system files....So, from my experience, if you received a Framework Error Caught ANSYS Workbench message then there is a 95% chance that your computer has registry problems..." 

There's quite a few freewhere/shareware tools out there that can help you clean up registry issues. I personally use CCleaner, but there are many others. Here's a good review from Tech Radar. 

So, use one of the mentioned tools to clean up your Windows registry, then reboot and launch ANSYS Workbench. Report back here if you have success.   

 

 

 

Loïc posted this 2 weeks ago

Hi !

I cleaned up my Windows registry with CCleaner, I rebooted and launched ANSYS Workbench but the same error message... I have even downloaded a new setup after that and cleaned up again but it did nothing. Have you another idea ?

Thanks

IngAEV posted this 2 weeks ago

I have done the registry cleanup aswell, and it doesn't work. The error keeps appearing. Help! I'm so behind on my homework u.u 

vganore posted this 2 weeks ago

This can occur if a C++/.net redistributable Ansys-prerequisite is not installed.

Missing MS VC++ 2012 Redistributable x64

IngAEV posted this 2 weeks ago

Thank you for answering, unfortunately it didn't work. The same error pops up. 

clsmyr posted this 2 weeks ago

I am having same error on Windows 10 64 bit.

Damn, i can not do my homework.

joaodaniel posted this 2 weeks ago

I had the same problem that you had and, fortunately, I found a solution. I hope it works with you too.

The problem was in the name of my user account. My name is a double name, so my user account has a space and, in addition, an accent as well. Ansys doesn't know how to read any of this characters. So, when it's searching for an archive necessary to open the program, it crash. It's like a bug or something, I don't know for sure. The fact is that Ansys doesn't know how to read strange characters in the names of the folders in which it is installed.

The solution was to uninstall the program, create a new user account (with letters and nothing more) and then reinstall it. Worked perfectly here.

  • Liked by
  • vganore
Close