Abnormal Exit Error

  • 298 Views
  • Last Post 14 January 2019
GabrielL posted this 09 January 2019

Hi all,

I have been using Workbench 19.2 (Fluent) for a while and I have recently repetitively experienced situations in which Fluent automatically shuts down occasionally when it was running, showing error messages "Abnormal exit!". What are the possible causes and remedy to this problem?

Thanks very much!

Order By: Standard | Newest | Votes
tsiriaks posted this 09 January 2019

Hi GabrielL ,

This symptom is definitely not common. 

Does this always/usually happen when you are doing certain tasks in the software (e.g., meshing, solving, rotating models, etc.) ?

There might be some information in your Windows Event Viewer. You can open that up -> Custom Views -> Administrative Events , then see if there is any event related to Fluent crashing logged in here. Another location you can check is -> Windows Logs -> Application

Also, can you try using stand-alone Fluent (not via Workbench) , do you experience the same issue ?

Thanks,

Win

GabrielL posted this 10 January 2019

Thank you for your reply.

Usually, this error happens during the solving process occasionally only. Otherwise, Ansys worked normally in other aspects.

I have checked the events log and revealed the followings:

 

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

  <System>

    <Provider Name="Application Error" />

    <EventID Qualifiers="0">1000</EventID>

    <Level>2</Level>

    <Task>100</Task>

    <Keywords>0x80000000000000</Keywords>

    <TimeCreated SystemTime="2019-01-09T16:50:41.335288700Z" />

    <EventRecordID>52675</EventRecordID>

    <Channel>Application</Channel>

    <Computer>DESKTOP-KJC3FR8</Computer>

    <Security />

  </System>

  <EventData>

    <Data>fl1920.exe</Data>

    <Data>0.0.0.0</Data>

    <Data>5b6b2ac7</Data>

    <Data>ABQSMARfmInterface.dll</Data>

    <Data>0.0.0.0</Data>

    <Data>53d35deb</Data>

    <Data>c0000005</Data>

    <Data>00000000000158d2</Data>

    <Data>3d4c</Data>

    <Data>01d4a836d11caa91</Data>

    <Data>C:\PROGRA~1\ANSYSI~1\ANSYSS~1\v192\fluent\fluent19.2.0\win64\3ddp_host\fl1920.exe</Data>

    <Data>C:\PROGRA~1\ANSYSI~1\ANSYSS~1\v192\fluent\fluent19.2.0\vki\win64\libodb6145\ABQSMARfmInterface.dll</Data>

    <Data>2364f447-1042-4b33-9480-9f1477b6c764</Data>

    <Data>

    </Data>

    <Data>

    </Data>

  </EventData>

</Event>

There was also a warning related to "Resource-Exhaustion-Detector".

Thank you very much for your help!

tsiriaks posted this 10 January 2019

I've never seen the issue with this dll. If it only happens occasionally, it could be specific to certain projects or certain things that those projects are using during the solve.

Please confirm this question, it could give some crucial information

"Also, can you try using stand-alone Fluent (not via Workbench) , do you experience the same issue ?"

Thanks,

Win

tsiriaks posted this 10 January 2019

I just got some information about that dll

It seems to be related to Abaqus. You might be missing some prerequisites.

Are you doing Fluid-Structure Interaction (FSI) simulation ?

Also, verify that this dll exists under that v192 folder  .......\v192\fluent\fluent19.2.0\vki\win64\libodb6145\ABQSMARfmInterface.dll

Thanks,

Win

GabrielL posted this 11 January 2019

Yes I'm doing Fluid-structure Interaction problems. They include simulation of a ship on water using VOF model and also wind flow around a building using LES. 

I have checked and verified that the dll .......\v192\fluent\fluent19.2.0\vki\win64\libodb6145\ABQSMARfmInterface.dll exists in the v192 folder.

I have also tried Fluent standalone (without Workbench). It seems similar problems occurred.

In fact, I have also experienced other problems when opening Fluent via workbench in which it shows "Fluent failed to validate the connection", usually when I update the upstream mesh file. These are usually solved by reloading Fluent but I'm not sure if this symptom has any further implications.

Thank you once again for your help!

 

Kremella posted this 14 January 2019

Hello,

Are you seeing this issue as soon as you open Fluent or do you see this issue when you are attempting to run a model (in the middle of your simulation)?

If this is happening in the middle of your simulation, could you please do the following?

  • Open Fluent in Standalone mode. 
  • Before you read your case and data files, please go to File -> Write -> Start transcript
  • Now run your model and see if the issue repeats. If there is an abnormal exit, Fluent should have written out the error message / issue in the transcript file. 

Could you please share a screenshot of the error here with us?

Regarding your other error "Fluent failed to validate the connection" - could you please share a screenshot of your workbench?

Thank you.

Best Regards,
Karthik

Close