Absent species do appear in residuals and seems to be produced

  • Topic Is Locked
  • 40 Views
  • Last Post 11 March 2019
Zari posted this 05 March 2019

Hi,

I have imported the GRI 3.0 chemical mechanism to Fluent. I am using it for combustion study in a small 3D geometry. The mechanism GRI includes 53 species. At moment I do not have any nitrogen at inlet boundaries where I set the inlet velocities and species. Therefore I expect that the model should not calculate those species that include nitrogen atom (hnco, cn, n2, no, no2,..). But now that the model is running I can see that residuals for these species are also being reported and calculated which is strange and they supposed to be 0, even if they being reported.

Why it is like that?

Here is how I have set my Species Model:

and as I mentioned above, N2 is not included in the inlets, so it supposed to be neglected, but now it it is produced in the model.

 

Appreciate your help in advance,

Zari

 

Order By: Standard | Newest | Votes
abenhadj posted this 05 March 2019

You do not  prescribe the abundant component at your boundaries (default). Moreover check what is listed under Select Boundary Species and Residuals.

Best regards,

Amine

Zari posted this 05 March 2019

I have set the boundary species as those I set amounts at inlets (O2, CH4, CO2), but for the reported  residual species I have selected all to be seen and reported.

I remember some other models that I calculated before, when an atomic component does not exist in the system (like nitrogen in this case), even if it is in the list of mechanism species, it cannot come up or produced.

abenhadj posted this 05 March 2019

I do not really understand: What is the problem here?

Best regards,

Amine

Zari posted this 05 March 2019

why should I see some N2 in the fluid zone, while I did not have it in my inlets? The amount is in magnitude of e-19 to -e20 (negligible), but it is there,close to the inlets.

So I am suspicious if a settings in Species Model or kinetic solver or mixture-material is wrong.

Here is the material settings for the Fluid zone:

Or maybe I should just neglect it since the amount is very low.

Regards,

Zari

abenhadj posted this 05 March 2019

Is N2 the abundant specie? Do the mass fractions at inlet and outlet sum to 1? 

Best regards,

Amine

Zari posted this 05 March 2019

Argon is the abundant specie. Argon has also some traces in magnitude of e-19, close to the fuel inlet.

The mass balance is like this:

Regards,

Zari

abenhadj posted this 05 March 2019

Might be rounding issue but to be safe: go in TUI and write /report/species-mass-flow right away after one iteration

Best regards,

Amine

Zari posted this 05 March 2019

Thanks for this method that I did not know about it.

I did it, and now I see some more strange things.

In the fuel inlet, I have only set CH4 and CO2. But now in the report (for fuel inlet) I see 6 more species with the same inlet magnitude as the fuel inlet species CH4 and CO2 (e-8 kg/s). Those species are: H2, CH2, CO, C2H2, C2H4, C2H6

for the oxidizer inlet it looks okay. O2 is the only species I set, and in the report it has a mass rate in order of e-7 kg/s and all other 52 species also appear in the oxidizer inlet, but the order is smaller than e-10 kg/s.

 The net mass-flow is not good for some species (those in an order of magnitude of e-7 and e-8 kg/s).

The picture has a good quality on my computer but it sounds unclear here, hope you can see it.

Best,

Zari

abenhadj posted this 05 March 2019

I cannot see sorry it is small. Are you enabling "inlet diffusion"? How are you initializing?

Best regards,

Amine

Zari posted this 05 March 2019

Yes, the inlet diffusion is enabled (figure at the first post).

I initialized from oxidizer inlet, but with a high temperature (1200 K) for ignition issues.

The model includes turbulence, combustion, radiation, and soot formation. It is going very slow and I hope I do not have to initialize it now, or should I?

Regards,

Zari

abenhadj posted this 05 March 2019

Just debug it step by step: Check the mass fractions at your inlet disable diffusion initialize and check the values of the flux again.

Best regards,

Amine

abenhadj posted this 05 March 2019

and I will at first disable all reactions in order to disregard the decay /birth of products/reactants.

Best regards,

Amine

Zari posted this 05 March 2019

very good idea,

I set it and leave it to calculate. I will write back the results later. 

Many thanks for your patience and assistance

/Zari

Zari posted this 07 March 2019

Hi again, sorry for my late reply.

After disabling the inlet diffusion, the inlet mass balance of species looks better. However the abundant specie appears at fuel inlet, and at outlet, which its amount at outlet is high!. I marked it with a red pen in the following figure:

The imbalance for mass flows is in order of 5e-12 kg/s, which might be neglected.

 Should I change the abundant specie?

Zari posted this 08 March 2019

I have edited the post above, and appreciate you can share your ideas.

abenhadj posted this 08 March 2019

I would say that is okay. Changing  abundant specie won't change anything here. Can you make a report after one iteration and double check the min max value of the mass fraction at inlet.

Best regards,

Amine

Zari posted this 11 March 2019

The model was running during weekend, and the report after few thousand iterations is similar to the previous report.

It shows:

- a fraction of Ar added automatically to the fuel inlet (-2.98e-13 kg/s)

- and much higher amount exits at outlet (-8 e-9 kg/s), the same amount is of course as deviation for Ar.

Is this usual and it does not affect the other species balance?

 

The report for species mass flows at boundaries is as below:

The overall flux at inlet and outlet boundaries sounds okay:

abenhadj posted this 11 March 2019

See my last answer.

Best regards,

Amine

Zari posted this 11 March 2019

 

Then you mean that it is okay. and I do not need to worry about the produced amount of the abundant specie.

Thanks

 

abenhadj posted this 11 March 2019

Also check the mass fractions at inlet and outlet straight after one iteration.

Best regards,

Amine

Zari posted this 11 March 2019

okay.

Here are the results for mass fractions of 3 boundary species (O2, CH4, CO2) , and the abundant specie (Ar), before and after 1 iteration:

All are the same at inlets, but mass fractions at outlet change in order of e-6 (Reactions inside the fluid zone are active).

abenhadj posted this 11 March 2019

And these results are with inlet diffusion switched ON or OFF? Do the values you are providing at inlet sum to 1?

The values are quite small. I would say one can neglect them if they are small then 1% of the smallest inflow/otuflow into the domain which they are..

Best regards,

Amine

Zari posted this 11 March 2019

The results are with inlet diffusion switched OFF.

The values I provided at inlets are molar fractions and they sum to 1. But Ar appears itself in the inlet boundary results and I do not have it in the inlet BC,.

abenhadj posted this 11 March 2019

To be followed up in another framework.

Best regards,

Amine

  • Liked by
  • Zari

Topic Is Locked

Close