AdditiveWizard Meshing Issue

  • 38 Views
  • Last Post 4 weeks ago
  • Topic Is Solved
jzuber posted this 17 April 2019

I am trying to utilize the AdditiveWizard extension in ANSYS 19R1 to simulate the metal 3D printing process for a school project. I have followed many of the steps that "Simulation Is Knowledge" has done in his youtube videos. This is about the only resource that I have encountered on the AdditiveWizard. I have set the system up so that the part being printed is directly on the build plate (no support material). Everything seems to be set up properly but when I try to run the transient analysis I run into the error seen below.

image.png

*** ERROR ***                           CP =       1.406   TIME= 19:04:57
 The mesh layer height 0 must not be less than the deposit thickness    
 1.E-02.                                                                 

 

I have looked around at mesh settings but I am unable to find anything on "mesh layer height".

 

I also have concern over not having an "AM Thermal Boundary Condition" when I utilize the Wizard extension in Mechanical. I notice that in the youtube simulations there is an "AM Thermal Boundary Condition". I am unsure if I am doing something wrong or if this is just a format change that ANSYS has introduced since the version of ANSYS (19.0) that he is using in his simulations.

 

If there are any ANSYS tutorial, tips and tricks, or forums for simulating 3D printing available for me to get more information about the process that would also be greatly appreciated. Additional applicable outside resources would also be useful.

 

Thank you for your time.

Order By: Standard | Newest | Votes
SandeepMedikonda posted this 4 weeks ago

The image is not properly attached. Can you please re-attach it?

The deposition thickness is the original laser thickness and in Mechanical, we are using a lumped layer approach. So, your mesh height can't be smaller than the deposition thickness. Also, you can change it here:

If you are not aware on how to insert this. Right-click on the AM Process object and select Insert > Cartesian Mesh. Notice that a Body Fitted Cartesian object has appeared under the AM Process object and become active and that all the bodies that are part of the build are selected.

In the help, there are 2 chapters on how to setup an additive simulation with & without the Additive Wizard. See here.

There are also 6 examples provided (including project files) in the Verification Manual. See here.

Useful Discussions:

Discussion 1

Discussion 2

Discussions with Emmanuel

Discussions with Ashish

Hope that helps.

Regards,
Sandeep
How to access online help

jzuber posted this 4 weeks ago

 I have tried changing the element size but that had not helped. I also tried inserting the "Body Fitted Cartesian" under the AM Process and changed that element size. I still receive the same error. 

 

" *** ERROR ***                           CP =       3.047   TIME= 13:01:29

 The mesh layer height 0 must not be less than the deposit thickness    
 2.E-02.    "

 

Note this is a different model than the first one (but same error message). I am not using any support material and am simulating the print right on the plate. Both of these models that have this error are angled outward when build up (aka the cross-section of layer n+1 is greater than that of n) however they are not much larger and are able to be printed, but I am thinking this could be causing the meshing error?

jzuber posted this 4 weeks ago

The inserted "Body Fitted Cartesian" under AM Process also is set to "No, overridden" under the active category. This is grey and cannot be changed. When the other "Build_and_Support_Cartesian" under the original mesh tree is suppressed the "Body Fitted Cartesian" under AM Process does become active but yields the same error.

jzuber posted this 4 weeks ago

I also have tried a model that was a bar with extruded wording which crashed due the same meshing error when trying to solve. The only model I have been able to run is a perfect cube.

SandeepMedikonda posted this 4 weeks ago

What version are you using?

Can you please post some snapshots of the model, your mesh and some the AM Process build settings?

As a test case, please take a model setup from the verification example manual as I previously linked to and try running it. Are you observing any errors?

jzuber posted this 4 weeks ago

I am utilizing ANSYS 19R1. 

Snapshots provided.

My set up is similar to that of the example. I utilized that along with the youtube video previously mentioned to set up my models.

 

jzuber posted this 4 weeks ago

Another model with the same mesh problem.

 

SandeepMedikonda posted this 4 weeks ago

Can you confirm that the build direction is in Z?

jzuber posted this 4 weeks ago

The build direction is global y.

jzuber posted this 4 weeks ago

Attached is the defined contact regions if that is your concern. I defined it utilizing my own created coordinate system.

 

SandeepMedikonda posted this 4 weeks ago

Ahh ok. There you go. So, the build direction always has to be the global Z. Please open the model in model in SpaceClaim and rotate it before you set up an additive run.

jzuber posted this 4 weeks ago

So I can build my model in SolidWorks and change the orientation in SpaceClaim (ie the global Z axis)? Also why does this matter and why does this error show up as a "mesh" error?

SandeepMedikonda posted this 4 weeks ago

Yes, you can if you had your CAD configuration properly setup you should be able to read your file in SpaceClaim or just rotate it directly in your CAD program of choice.

Additive technology works on the principle of element birth and death in the build direction of the machine. This is pre-defined to be Z. It is stated in the docs.

Since it is trying to build the part in Z, it doesn't notice an element at the very start and hence the error about zero height or the mesh height being less than the deposition thickness.

jzuber posted this 4 weeks ago

The global Z axis was the problem. Thank you.

Close