Ansys 19.0 - will not create mesh

  • 5.8K Views
  • Last Post 12 November 2018
morsan posted this 15 February 2018

My first post here!

I have just installed R19.0 and have trouble meshing a simple beam (or any other object I have modeled). Everything else seems to work.

 

When meshing I get the following errormessage:

The mesh generation did not complete due to poor quality elements or incorrect input. Please try meshing with another mesh method or different mesh options.  

Instead of explaining what I have done in words, I have put up a video showing my steps. Hopefully someone can tell me what I am doing wrong!

Order By: Standard | Newest | Votes
arct posted this 15 February 2018

Have you tried doing as error says- with smaller mesh and different methods, for instance proximity instead of curvature?

vganore posted this 15 February 2018

Can you try setting up relevance to 100 instead of zero. Also use fine mesh option. See if it works out. 

Vishal Ganore, ansys.com/student

morsan posted this 15 February 2018

Thanks for tips on my mesh issues.

 

As I am pretty unfamiliar to Ansys, I had just tried the default mesh setting (adaptive size method). Besides Adaptive, I have now tried all the other methods, but the error remains. I have also tried to set relevance to both -100 and +100, and relevance center to Coarse, Medium and Fine. When using the Proximity method, I have tried to adjust Max Face Size with no luck. I have also tried to ignore mesh errors (Check Mesh Quality setting).

 

It would be nice if anyone could share a simple beam model that work on their computer to rule out that my settings are the problem.

 

arct posted this 15 February 2018

Or maybe just reinstall ansys?

peteroznewman posted this 16 February 2018

I have a fresh installation of ANSYS Student 19.0 and it makes a mesh without any problem. Try to reinstall.

 

morsan posted this 21 February 2018

I have reinstalled the software (cleaned up every trace I could find of the previous installation before reinstallation), but sadly, the result remain the same. On the same pc, I have an installation of Ansys Student Discovery Live that works without any issues.

  • Liked by
  • aniket287
IC87 posted this 13 September 2018

Hi all

I have the same issue as morsan. 

"The mesh generation did not complete due to poor quality elements or incorrect input. Please try meshing with another mesh method or different mesh options"

I have tried to reinstall, update drivers, change geometry, mesh size, type... and now I have run out of options.

Has anybody solved the problem? Any help would be much appreciated!

SandeepMedikonda posted this 14 September 2018

Hi, Are you also using 19.0?

I just tried everything the same way in 19.0 as well and had no problems...

P.S: In the future, please start a new discussion. Older posts or long threaded posts tend to get less attention. You can always link it to the older post if you want to do so.

Regards,

Sandeep

DavidY posted this 14 September 2018

Hello,

Could you please try and reinstall the prerequisites for us? The default program to run is:

C:\program files\ansys inc\ansys student\v190\productconfig.exe

Make sure you Run as Administrator. Click on Install Required Prerequisites. Let us know if that fixes it for you.

Thank you.

  • Liked by
  • SandeepMedikonda
SandeepMedikonda posted this 14 September 2018

Also, if it doesn't work. Can you post an image of all the details included under Meshing?

Regards,

Sandeep

luizjr0 posted this 16 September 2018

Hi,

I am having the same problem with Ansys 19.1. I tried to reinstall the prerequisites as DavidYakinian suggested but the problem persists. I cannot create the mesh even with a very simple geometry. I made a video to show exactly the problem. Please watch using the link: https://drive.google.com/file/d/1ZRy_ujZ5uQnmgyTBOyeKcUN0BZLGBrJV/view?usp=sharing

 

 

Thank you.

 

SandeepMedikonda posted this 16 September 2018

Can you upload it to Youtube and provide the link here? We are unable to access the drive location.

Can you please post some snapshots of all the Details of "Mesh"? Expand everything, Sizing, Quality, Inflation, Advanced and Statistics?

This is a very rare problem and it is hard to debug as we are unable to reproduce it, If you are at a university have you tried on a different computer or even a friends computer (please make sure you use the same ANSYS download)? This is not a fix but might get you going and eliminate any problems with the installation file.

Lastly, can you please provide complete details of your machine, configuration etc?

Regards,

Sandeep.

luizjr0 posted this 17 September 2018

SandeepMedikonda please find below the link for the video on youtube.

I will take some more snapshots later with the mesh details. This problem happens with any mesh. In the case of the video, I am trying to generate a simple default mesh.

Yes, I am at a University and this problem is happening in all the computers that have the 19.1 version installed that I tried (4 different machines).

Later I will post the details of the machine as well.

Thanks.

SandeepMedikonda posted this 17 September 2018

Ok, yeah. Please provide those details and also the University name?

Once you do, I'll try to reach out to your account manager and we can work from there. 

If the problem is replicable on all machines at one university, it is possible that some anti-virus or an application might be blocking the meshing executable from running.

Can you confirm if this is a problem with a previous version as well, i.e., 18.1 or 18.2?

Regards,

Sandeep

luizjr0 posted this 17 September 2018

SandeepMedikonda, Please, see below the details of the mesh (everything on "Default"). The machine I am using has the following configuration:

Intel Core i7-4790 CPU 3.60 GHz

Installed memory (RAM): 8.00 GB

System: Windows 10 Enterprise x64

 

I am writing from the University of Nevada, Reno. 

The problem occurs in the 19.1 version only. The computers with previous versions installed (18.2, 18.1, or 17) do not present the error. 

 

 

Georgiro posted this 07 October 2018

I am not speaking about meshing, but creating models! So I am not able to create a simple line, Only the first point to do and not to create the second one. So I am not able to create anything at all! Thanks for understanding!!!

Georgiro posted this 07 October 2018

So as I said the problem is on Ansys 19.0 and also on 15.0.7, so before I used normally 15.0.7, but I cannot now. So what can be the problem? Thanks

Georgiro posted this 07 October 2018

 Basically, please, read this, because I am not able to create even 2 points of a geometry, not a plane, etc. So can you please start to think about it. And this happend on my before using 15.0.7 and now 19.0. Absolutely impossible to work with it!!! Thanks for understanding

§

peteroznewman posted this 07 October 2018

Let's get your license issue resolved in the other thread.

SandeepMedikonda posted this 29 October 2018

luizjr0, 

Getting some logs would help out.   The only personally identifiable information in these logs will be folder names.  No geometry, model, mesh data, or machine identities will be logged.

* First though, perhaps it is a permissions issue.  Are you running as admin or have admin privs?  Are they installed in default location?  What is the location of the TEMP folder via %TEMP% and do they have proper write access to it?  (Meshing will create a subfolder in here, so there should be a %TEMP%/AnsysMeshing folder as they tried to run mesher)

* Second thing I would look for real quick is seeing if the problem is unique to sweeping (as this model is sweepable).  

Right click Mesh, choose Insert --> Method.

In details view, click Geometry.  Go click the cuboid in the Graphics window, then back to Geomery and click Appy.

In the details view, change the Method field to Tetrahedrons and try again.  Change it to Multizone and try again.

* Still no answers... move on to logs:

Turn on Beta Options:  Workbench Project Page, Tools -->  Options -->  Appearance -->  (scroll down)  Beta Options

In Mechanical, right click Mesh, and select Diagnostics (Beta) -->  Enable DSMesher Logging

Generate Mesh.

This will create logs in %TEMP%/meshlogs

* If Diagnostics is not available (older version), or we don't get a meshlogs subdirectory, activate logging manually and keep logs out of the TEMP folder.

1. Close Workbench down completely.

2. Find the attached file (AnsMeshingKeys.xml) which contains keys that will activate logging.

Copy this file to a location that has write access. (I place it on the D:\ root)

3. Open the file, and in line 3, change the value to a directory where they want to dump the logs into. (I have it set to D:\MeshingLogs\)

4. Create the directory to ensure it exists and is writable.

5. Create an environment variable that points to the folder where the xml file is located  (Notice, no trailing slash)

AnsMeshRegistry=D:

6. Restart Workbench so that is consumes the new environment variable.  Run the entire workflow.  Several log files should be generated in the directory you chose earlier.

The files will be helpful to us if they can be sent it.

Remove/rename the environment variable to turn off the logging behavior whenever desired. 

Regards,
Sandeep

Georgiro posted this 12 November 2018

What I have made is to reinstall Windows 10 Home and it started to work it normally. But, so much thank you!

Close