ANSYS 19.1 installation on Linux

  • Last Post 21 January 2020
  • Topic Is Solved
pcaicedo posted this 25 August 2018

Hi all,

I have been trying to install ANSYS 19.1 on Linux for half day, and it remains at 89% of the installation for so long. It may be some errors because the administrator of the cluster have tried too and had the same problem.

It would be great if someone could help me to solve this problem.



Order By: Standard | Newest | Votes
tsiriaks posted this 27 August 2018

Hi Paul,

Please provide the output of 

cat /etc/*release

Then, refer to the Linux Installation guide Chapter 2 : Platform Details . This Chapter would list all prerequisites for different OS level. Make sure that the prerequisites are installed.

Also, don't install it on your home directory. Ask your cluster admin to install it in the directory that's accessible by any users.

Thank you,



  • Liked by
  • pcaicedo
pcaicedo posted this 27 August 2018

Hi Win,

Here is the output

CentOS Linux release 7.4.1708 (Core)

NAME="CentOS Linux"

VERSION="7 (Core)"


ID_LIKE="rhel fedora"


PRETTY_NAME="CentOS Linux 7 (Core)"











CentOS Linux release 7.4.1708 (Core)

CentOS Linux release 7.4.1708 (Core)

Do I need install all the libraries indicated in CentOS 7.3 even if my version is 7.4.1708? I can't use sudo; how could I install the libraries?

I am reading that chapter to check what I am missing, but at this moment I need to install in my home directory because the cluster admin spent a day trying to install in the directory that's accessible by any users without any luck, and he is not willing to spend more time, so if this works in my home directory he will scale up.


jcallery posted this 27 August 2018

Hi Paul,

Please try installing libpng12.
Something like:
yum install libpng12

Thank you,


pcaicedo posted this 27 August 2018

Hi Jake,

It says this

Loaded plugins: fastestmirror, langpacks, priorities

You need to be root to perform this command.

So, I think there is no option to install those libraries if I am not the admin of the cluster, right?



jcallery posted this 27 August 2018

Hi Paul,
Correct, the admin will need to install that library.  It is required to finish the installation.

Thank you,

  • Liked by
  • pcaicedo
hose posted this 02 December 2018

Hi Jake,

I have same problem with installing ANSYS 19.1 on suse 15. It stuck in third installation disk and never progress the installation. The command cat etc/*release gives:

PRETTY_NAME="SUSE Linux Enterprise Desktop 15"

Also I installed libpng12 on the machine and tried to install ANSYS as root, but did not work.


Thanks for help



jcallery posted this 03 December 2018

Hi Hosein,

Unfortunately Suse15 is not on the list of support platforms.  Please see the .pdf here:


My suggestion would be to switch to a supported OS.


Thank you,




apurba posted this 25 January 2019

Hi pcaicedo,

I too faced similar situation while installation of Ansys 19.0 in my Ubuntu 18.04. and followed the steps of correction as suggested in the posts above. Would you tell if the same is solved or not and how?

Thank u,


tsiriaks posted this 25 January 2019

Hi apurba ,

You might be able to get past this issue with

apt-get install libmotif-dev

apt-get install lsb

However, please note that Ubuntu is not supported and it's very likely that you will run into other issues. The best bet here is to use CentOS , SLES, or RHEL



apurba posted this 09 February 2019

Hi tsiriaks,

thanks for u'r reply. I have changed my platform. Installed in CentOS7. Installed successfully. However there's a different issue. Workbench is opening, but while using static Structural  block, I am unable to open the geometry editor. Here's a snap of what happened. How to sort out this issue!!

jcallery posted this 11 February 2019

Hi apurba,

Can you please post screenshots of the following commands:

cat /etc/*release*

lspci -nnk | grep -i vga -A3 | grep 'in use'

glxinfo | grep -i "opengl renderer"


Thank you,


hisham posted this 19 March 2019


I also had exactly the same problem during installation of Ansys 19 on Linux mint OS, the installation stops by 89%.

I am very new in using Linux, so I would highly appreciate if you can answer in simply or provide direct links if I need to install some other preliminary software.




jcallery posted this 19 March 2019

Hi Hisham,

Unfortunately MintOS is not a support OS.

Please see the platform support document here for a list of supported operating systems:


Thank you,


MemoriseXuxu posted this 13 October 2019

Dear Jcallery

I come across the problem he mentioned.

MemoriseXuxu posted this 13 October 2019

Some parts of the WB cannot be opened.But the Fluent and CFX work fine.However, the Mesh,the Modal, the Transient Structure cannot be opened.

I'm doubted what the problems is.

Thank you guys.

jcallery posted this 14 October 2019

Hi MemoriseXuxu,

Please create a new topic for your issue if the following does not solve your problem.


You do not appear to have any hardware graphics acceleration, which is most likely your issue.

We can try forcing Workbench etc.. into a software rendering mode, but I can't promise it will work.

From the terminal enter:




Now try launching workbench from that same terminal session.


Thank you,



MemoriseXuxu posted this 16 October 2019

Hi, Jcallery

Thank you for your support!!!  And I will have a try on it. But I have a doubt whether the external graphics is necessary. Beceuse this node doesn't have the graphics cards. However, my other compoent like Fluent and CFX works fine with GUI.And my CPU is Xeon Gold 5188.

Or if I install the GraphicsDriver correctly, it will be OK ?

And I read the discussion below which the libpng12 is mentioned. Is it the problem ?

Thank you


tsiriaks posted this 17 October 2019

Hi Xuxu,

Different tools in ANSYS have different requirements for graphics. When you don't have a good dedicated graphics card, some tools may not function correctly. The software rendering mode that Jake mentioned could sometimes help out in this situation. But I would recommend to try all of the followings to make sure you are using Mesa library as well




export LD_LIBRARY_PATH=/ansys_inc/v195/Framework/bin/Linux64/Mesa

/ansys_inc/v195/Framework/bin/Linux64/runwb2 -oglmesa



MemoriseXuxu posted this 18 October 2019

Dear Win,

I'm using the Nvidia P6000 Professional Cards. Is it the problem of graph driver . 

What's more , it is necessary to enter the code that Jake mentioned every time I use the WB.



tsiriaks posted this 18 October 2019

Hi Xuxu,

Yes, in that case, there is some issue in systems/graphics setup that doesn't use your Nvidia as default.

If everything is setup properly, output of these commands have to be all Nvidia

lspci -vnn | grep VGA -A 12

glxinfo | grep OpenGL


By the way, if you want to keep using software rendering mode for now, you can permanently set those environment variables, so you don't have to do it each time/terminal.



yskale posted this 21 January 2020

Hi ,

I am installing Ansys 19 on SUSE 15.... when I try to run the ./INSTALL it gives me following error 

 Executing /tmp/ans_install_tmp22270/instcore
instcore: cannot connect to X server localhost:0