Ansys 2019 R1 extensions not activated / not working.

  • 38 Views
  • Last Post 5 days ago
fala posted this 2 weeks ago

Hello,

I am a student using our university license. I am fairly new with Ansys software. When i open the Extensions Manager, there are no extensions, the windows appears gray.  Even when I went on the customer portal and install extensions, i couldn't see any in Extension Manager. I reinstalled the the entire Ansys 2019 R1 package multiple times and the issue is still there. My problem is lot of students have the software working properly on their computer.  I was wondering if there is a problem with my extensions path or not. 

I am not sure where too look. I went on some forums and did a few tests but still couldn't figure it out. 

Please help if you have some advises. 

Best regards, 

 

Order By: Standard | Newest | Votes
rwoolhou posted this 2 weeks ago

What extensions are you missing? 

fala posted this 2 weeks ago

rwoolhou

Thanks for getting back to me. None of the extension is loaded with the workbench. other students in my groups after the install have 4 defaults extensions listed in their Extensions Manager.

As part of the project i need to install the model reduction extension " MORACT extension " . i have tried and it was not working. I was told i have to figure out first why the defaults extensions are not loading with my workbench before proceeding with MORact extension.

extensions manager . 

 

 

 

 

 

 

 

tsiriaks posted this 2 weeks ago

Your machine may have FIPS enabled.

If you open CMD Prompt, and use the following command

reg query "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy"

what do you get ?

If 0x1, it means it's enabled, I would recommend to find online steps to disable it.

If 0x0, it means it's disabled, in this case, I would recommend to try temporarily turning off all of the security software on the machine (Anti-virus, Firewall, etc.) just for a test and see if you can see ACT extensions. If so, turn those back on but add 'exclusions' to ANSYS folder.

Thanks,

Win

fala posted this 2 weeks ago

The following is what i got. I disabled all firewall and antivirus, still couldn't see any extensions.

 

 

cmd

Thank you

tsiriaks posted this 2 weeks ago

Make sure all ANSYS Applications are closed, then open CMD Prompt, and issue this command

move %appdata%\ansys %appdata%\ansys.old

If that doesn't work, while Workbench is open, launch Windows Task Manager and see if you have process named Ansys.ACT.Browser.exe

Thanks,

Win

fala posted this 1 weeks ago

The issue is still there. my workbench is loading without extensions. 

the task manager is not showing any process named Ansys.ACT.Browser.exe

Thanks.

 

cmd

tsiriaks posted this 1 weeks ago

Something on this systems is preventing the Ansys.ACT.Browser.exe process to run. 

Are you using VPN ?

If not, I'd suspect your Avast security causing the issue. The Ansys.ACT.Browser.exe process 'uses' web browser in the backend, so you may need to disable Avast Secure Browser as well. Or if possible, I would say uninstall it for a test and see if it makes any differences. If so, reinstall Avast and find which Avast tool is blocking it.

Thanks,

Win

fala posted this 1 weeks ago

I am using the university VPN, I also have local wireless internet connection. 

I uninstalled Avast  and took off the Firewall and it makes no differences. 

 

Thanks.

Fala

tsiriaks posted this 1 weeks ago

Hi Fala,

If VPN is being used, that's actually the prime suspect. Can you disconnect from VPN, reboot the machine, then connect to the university network directly (using LAN/Ethernet) and see if that makes any differences. Make sure you turn off your Wi-Fi as well.

Thanks,

Win

fala posted this 5 days ago

Hallo Win,

I was at the University today. I connected the Laptop to the network via LAN/Ethernet cable. The extensions manager is not showing any extensions even with Avast disabled. The task manager is not showing Ansys.ACT.Browser.exe. 

There is a warning message " Cannot establish a connection with the license server system for the CADFEM Extension(s). "

Thanks 

 

 

tsiriaks posted this 5 days ago

Hi Fala,

I think this 

There is a warning message " Cannot establish a connection with the license server system for the CADFEM Extension(s). "

is a different issue.

But the main issue is that your ACT browser couldn't launch at all.

Let's focus on the setup that you connect to the network directly, not connect to VPN, and disable Avast like what you did above, to eliminate any other possible issue that could get involved.

I wonder if Windows Defender (both virus protection and firewall) kicked in while Avast was disabled ?

Can you open up CMD Prompt and issue the following commands

ping localhost -4

ping %computername% -4

then post the output of them here

Thanks,

Win

Close