ANSYS AIM/ MemoryError

  • 20 Views
  • Last Post 22 February 2019
xingguan posted this 18 February 2019

Hello everyone,  

I met a problem during a simulation, the probelm was: 

Error at  Node x : MemoryError: bad allocation. Does anyone knows what may cause this problem? And how could i fix this?

 

Thanks a lot!

Attached Files

Order By: Standard | Newest | Votes
abenhadj posted this 18 February 2019

Please add more info about your case: Fluid or Structural? Release Version?

Best regards,

Amine

xingguan posted this 18 February 2019

Fluid Simulation, Release 19.0

abenhadj posted this 18 February 2019

And more information: When does it happen?

Best regards,

Amine

xingguan posted this 18 February 2019

I was taking on a transient simulation with thousand time steps for 2 seconds. But after 250 global iterations (planed: 1000*10 Iterations) the simulation has broken up suddently with those Errors.

Mesh quality and boundary conditions have been checked, mesh elements was around 500 000. 

xingguan posted this 18 February 2019

Hello Amine, 

do you have any idea, whether this problem may come from my model? and could come from where?

Thanks a lot.

abenhadj posted this 18 February 2019

So it just appeared. How many nodes are you using? Are there any other messages written? What kind of physics do you have? 

I recommend testing with newer versions and if you encounter same error then we can discuss again.

Best regards,

Amine

abenhadj posted this 22 February 2019

The error tells you that it runs out of memory.

Best regards,

Amine

Close