Ansys Fluent dynamic mesh works in preview, but crashes in calculation

  • 47 Views
  • Last Post 13 September 2019
  • Topic Is Solved
MrRioes posted this 04 September 2019

Hello,

I'm running into a strange problem. I am running a transient flow simulation in Fluent. In this simulation there is a moving flap in the outflow of a pipe. For the moving part I am using dynamic meshing. I played around with the settings and the initial mesh, so that it seemed appropriate for the dynamic meshing. 

When I preview the dynamic meshing process in Fluent, everything seems to be ok. No faults or errors and the mesh looks fine. But when I start the calculation process (same time step as in the preview process) after 40 to 50 time steps, I get the error message of negativ cell volume. This doesn't happen in the preview process. There the mesh behaves fine for 500 time steps.

What could that be ?

Order By: Standard | Newest | Votes
abenhadj posted this 04 September 2019

Does the motion depend on flow field/properties etc..?

Best regards,

Amine

MrRioes posted this 05 September 2019

No the motion doesn't depend on the flow etc.

abenhadj posted this 05 September 2019

Quite weird: which release version are you using? 

Have you tried reducing time step size with flow ON?

Best regards,

Amine

MrRioes posted this 06 September 2019

I am working in Fluent 19R2. 

Now I tried a few things, i've seen the mesh motion in all but the last step is fine.  So I played around with some more parameters, and now it works. Don't know why, but it works.....

I will attach some pictures where you can see the problem.

This is while preview, the time step is 0.001s and it goes till step 22

Here the mesh while calculation, same time step of 0.001s and step 22

abenhadj posted this 06 September 2019

What have you changed so that is working now?

Best regards,

Amine

MrRioes posted this 13 September 2019

sorry for the late response but i was a bit busy.

To get it running i seperated the boundary mesh form the rest of the mesh. Then i defined for this mesh the same rigid body movement as for the moving wall. So it wouldn't "blow up" anymore.

abenhadj posted this 13 September 2019

Thanks for updating the group. Please mark this then as "is Solved". There is an option to deform adjacent boundary layer zone to keep the mesh quality safe. You might try that if it resolves the issue. But still weird that the you require that only when flow is solved. 

 

Anyway happy to see progressing.

Best regards,

Amine

Close