ANSYS License Manager Error

  • 3.3K Views
  • Last Post 03 December 2018
stevenkwan18 posted this 25 August 2018

I am a student, I currently just installed ANSYS 19.1 Student version and after installation, I am having a problem when starting Fluent in Setup. This message appears:

ANSYS LICENSE MANAGER ERROR:ANSYSLI exited or could not read server port ANSYSLI_DEMO_PORT.

Anyone has encountered the same issue?

I need help please

Attached Files

Order By: Standard | Newest | Votes
tsiriaks posted this 27 August 2018

Hello stevenkwan18,

Have you tried the suggestions from this post ?

https://studentcommunity.ansys.com/thread/workbench-error-3/?order=all#comment-99282690-f583-4eb6-8cd7-a94201170e43

Let us know how it goes.

Thank you,

Win

jackhero posted this 25 November 2018

I installed Ansys 19.2 (student version) on my system and also facing this issue. I followed the instructions given at this link but didn't work. Any other suggestion on solving this issue.

In addition, I would like to ask is this issue somehow related with the Design Modeler in Ansys Workbench? I am trying to open the DM but is not opening.

tsiriaks posted this 26 November 2018

Hi jackhero,

Can you ping your own hostname ?

Let's focus on this licensing issue first and see if it also fixes your issue with DM.

Thanks,

Win

jackhero posted this 28 November 2018

Yes, I can ping my own hostname without any loss.

tsiriaks posted this 28 November 2018

Hi jackhero,

Try open %appdata%\ansys\ANSYSLI_DEMO_PORT with any text editor app like notepad, etc (don't use this app with 'run as admin'). Then, do some modification to the file and see if you can save it.

If that doesn't help, open CMD Prompt and type the followings

set t

and

set appdata

then post the output of each command here

Thanks,

Win

  • Liked by
  • jackhero
jackhero posted this 29 November 2018

Thank you for your reply.

I opened %appdata%\ansys\ANSYSLI_DEMO_PORT with notepad, the file had default value of 0 only. I changed it to 2 and then save it. After saving I re-opened the file to check if the modification is still there or not, and the file had the value of 2 after re-opening. So the modification and able to save or not both are ok.

After modification I ran ANSYS, when ANSYS opened I had the same error. I checked the file which I modified earlier, the modification was gone and it again had the value of 0.

For the CMD commands the results are as under;

for set t I had the following output,

TEMP=C:\Temp
TMP=C:\Users\muhd_\AppData\Local\Temp

for set appdata I got the following output,

APPDATA=C:\Users\muhd_\AppData\Roaming

tsiriaks posted this 29 November 2018

Thanks for the info.

Try, open CMD Prompt and issue the following commands 

move %appdata%\ansys %appdata%\ansys.bak

set TEMP=C:\Users\muhd_\AppData\Local\Temp

"%awp_root192%\Framework\bin\Win64\runwb2"

 

If you still get the same issue, can you try creating a username that doesn't have _  ? Maybe something like muhd , then see if you still get the issue.

Thanks,

Win

jackhero posted this 01 December 2018

Thank you for your reply. I followed the instructions but regret to say I am still getting the error. I have attached the screenshot below which I took after following the instructions.

I am also not getting the complete component systems (like options of static structural, explicit dynamics etc). I also tried adding through the Toolbox under view but it didn't work. I assume may be this issue is also due to the error I am getting (shown at the bottom of the image).

tsiriaks posted this 03 December 2018

Yes, these are all the results of the application couldn't pull licenses.

Could you try creating a new username as described ?

Thanks,

Win

Close