Ansys Mechanical APDL 2019 R1 doesn't run.

  • 830 Views
  • Last Post 08 May 2019
  • Topic Is Solved
Williamdame posted this 07 May 2019

Hi,

 

I installed the student version, if I try to run the Workbench it goes ok, but when I try to run 'Mechanical APDL 2019 R1' it doesn't work. It simply doesn't open any window. 

 

I have a mac pro 2014. I am running Windows 7 in VMware Fusion.  

Order By: Standard | Newest | Votes
pgl posted this 07 May 2019

Hi Williamdame,

Unfortunately we don't officially support our software running on virtual machines on macs.We support VDI with Window/Linux as the client, using Windows/Linux operating systems. Our supported platforms are listed here. 

Best I can suggest is to switch to a supported platform, which I know is not the answer you wanted to hear! Sorry :-(

Maybe other users on the Student Community could chime in with their tips?

Regards,

Paul.

tsiriaks posted this 07 May 2019

Hi Williamdame,

I agree with Paul that you should find a supported platform and use it with ANSYS products but I do have some things for you to try with your current setup.

Open up CMD Prompt, then issue the following two commands

set PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem

"%AWP_ROOT193%\ANSYS\bin\winx64\launcher.exe" -runae

does this make any differences or do you see any error message at this time ?

Thanks,

Win

  • Liked by
  • Williamdame
Williamdame posted this 07 May 2019

Hi tsiriaks, 

 

I issued yout commands, but it still doesn't work. I don't know if I agree that the Ansys doesn't work on virtual machine because all of the others Ansys programs are running nice. 

I am sending a screenshot of what happens when I try to run it. After what you can see in the image, it just disappear of the screen. If I go to the Task Manager in the tab "processes", I can't find any Ansys running there too.   

tsiriaks posted this 08 May 2019

Hi Williamdame,

Somehow it 'solves' something as opposed to try to startup M-APDL GUI. 

Let's do this. Please use these two commands instead

set PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem

"%AWP_ROOT193%\ANSYS\bin\winx64\launcher.exe"

then once you are on the M-APDL Launcher GUI, take the screenshot of all 3 tabs in that GUI and post them here.

Thanks,

Win

Williamdame posted this 08 May 2019

Hi tsiriaks,

Here you go my friend:

tsiriaks posted this 08 May 2019

On the last tab, what if you select the SMP (Use Shared-Memory Parallel) instead ? Does this make any difference ?

Thanks,

Win

  • Liked by
  • Williamdame
Williamdame posted this 08 May 2019

Hi tsiriaks,

Now it is working very well! Thank you so much! So, the virtual machine is not so bad. 

Thanks, man!!! 

tsiriaks posted this 08 May 2019

Great ! Glad the SMP mode works for you. To run DMP, you may have to check MPI or security/anti-virus software on your machine to make sure it can allow ANSYS to run in distributed mode.

If you are good for now, please mark this thread as 'resolved' ('Is Solution') , so we know it's been addressed.

Thanks,

Win

Close