Ansys Mechanical APDL, GPU acceleration

  • Last Post 17 September 2019
  • Topic Is Solved
sahsonas posted this 05 September 2019


Can anyone tell me how to enable or activate GPU acceleration on Ansys Mechanical APDL 18.2 ?

I have the following specs:

Operating System: Windows 7 Professional x64

Processor: Intel(R) Core(TM) i7-4930K CPU @ 3.40 GHz 3.40 GHz

Installed Memory (RAM): 32 GB

GPU: NVIDIA Tesla C2075 and NVIDIA Quadro 2000

CUDA version: 6.0

CUDA runtime: 6.0

Graphics Driver: NVIDIA 332.88 (checked with GPU-Z) 


Note that I have already applied these methods.

Method 1. In Mechanical APDL, Tools > Solve Process Settings > My Computer > Advanced>

   Max number of Utilized cores: 4      Use GPU acceleration: NVIDIA      Number of utilized GPU devices 1 (also checked with 2)

Method 2: In System variables, Add new variable> 

   Variable Name: ANSGPU_OVERRIDE      Value = 1.


However, I am still getting an error saying that:

*** FATAL ***

An error has occured when trying to check for any GPU devices on machine. Error code = 35 which translated to: CUDA driver version is insufficient for CUDA runtime version. Please check your GPU device driver level and verify that a supported GPU device has been installed correctly.

Note that I tried to install CUDA 10, 8, 7.5, and 6.5. I got the same error on every version of CUDA. Now CUDA 6.0 is installed in the system

NOTE: I checked on Ansys Fluent, using /parallel/gpgpu/show. Both of the GPUs are shown and starred.


Please guide me about how to activate and utilize the GPU on my workstation. 



Order By: Standard | Newest | Votes
sahsonas posted this 07 September 2019

Is there anyone who can share his expertise on the discussion started here?


rwoolhou posted this 09 September 2019

First thing to check is whether the graphics card is compatible: 

I'll also move to the Installation section as it's hardware related. This section is for software interaction eg FSI. 

  • Liked by
  • sahsonas
sahsonas posted this 09 September 2019

Thanks for your response.

The graphics card is listed to be compatible and tested on Windows x64. Tesla C2075 is listed in TESTED cards.


tsiriaks posted this 09 September 2019

What if you disable your NVIDIA Quadro 2000 or upgrade its driver to

while leaving your Tesla as-is.


If those don't work, try both of the above again and upgrade your Tesla CUDA runtime/driver version to 8.0

  • Liked by
  • sahsonas
sahsonas posted this 16 September 2019

Hi Tsiriaks,

Thanks for your guidance. The first option has solved the problem.

Installed driver is now NVIDIA 377.83 with CUDA Toolkit 8.0.

tsiriaks posted this 17 September 2019

That's great !

Thank you for the update. I'm glad it's working for you.


  • Liked by
  • sahsonas