Ansys Piezoelectrics and Mems expansion, cant apply voltage to harmonic analysis

  • 172 Views
  • Last Post 09 June 2019
qdb15143 posted this 16 January 2019

Hi all,

I've been attempting to model a piezoelectric bimporph with the ansys piezoelectrics and mems addon, and everything works fine (static structural, modal) untill i get to the harmonic analysis. At this point im never able to apply voltages to surfaces as this option is greyed out, the only option is Enforced Motion voltage, every time I use this option however my model won't solve for whatever reason (an error occured inside the solver module: general error).

I am new to this so even if you think your solution to be too obvious, please let me know nontheless.

Cheers,

Ben.

Attached Files

Order By: Standard | Newest | Votes
jj77 posted this 18 January 2019

I am not familiar with the specific act, but in the end of the day, act ext. run in the background apdl commands.

 

Thus you can put one in your self via the command snippet.

 

Before that, define two named selections of the positive (called positive say) and negative electrodes.

 

Finally apply a voltage boundary condition (via apdl commands) like this (800 harmonic voltage, and zero on negative, so grounded).

 

d,positive,volt,800

d,negative,volt,0

 

There is a video called: ansys cae 16 harmonic response analysis, for more details.

Jkjkjk posted this 09 June 2019

Problem solved mate?

I am having the same issue.

Jkjkjk posted this 09 June 2019

it seems that i solved the problem by playing around. As highlighted in the attach image, change the solution method to "Full", and you will be able to use voltage.

btw, i am new to anasys and FEA as well. lots to learn...

 

Close