Release 18.2 Workbench is not opening (Framework Error Caught)

  • Last Post 24 January 2018
  • Topic Is Solved
clsmyr posted this 08 October 2017

Ansys Workbench is not opening due to this error.

I am using Windows 10 64 bit. Downloaded student version 18.2

I tried to reinstall net framework and vc stuff, does not work. I reinstalled ansys, doesnt solve the problem.

I need to do my homework, application doesnt work. What should i do?

Order By: Standard | Newest | Votes
clsmyr posted this 09 October 2017

Solution: This damn error is caused due to your Windows User Name.

You need to change your user name(dont use blank and any other special character, just use letters which found in english alphabet)

to do this: Remove Ansys 18.2

Windows + R > netplwiz > double click on accound, change your account name as stated above.

Reinstall Ansys18.2

Damn, this shouldnt be so hard.

  • Liked by
  • vganore
pgl posted this 10 October 2017

Please see this post also, it covers why you shouldn't use special characters in your account (and thus folder) names:

clsmyr posted this 10 October 2017

I think it is not related with install location, because I directly extracted installation files on C:\ansys folder.

Also, I am from turkey and I have a Turkish specific character in my name. So my user name is not a fancy choice

Creators of an widely used engineering program should consider different alphabets found among world, dude it is 21th century.

pgl posted this 10 October 2017

After >15 years of ANSYS Workbench being available with many users in Turkey this issue hasn't been raised before. So I'm pleased that this Student Community allows you to share this feedback, so thank you - I'll pass this along to our installation development team for review.  In the meantime you have your workaround, I admit its not ideal as it's your name, and you'd like to use it as it was intended. 

clsmyr posted this 11 October 2017

Thank you sir, by the way I don't mean to be rude here. If I was rude I am sorry, maybe it's a Windows 10 issue.

I spent several hours on the computer. I reinstalled lots of stuff again and again. No solution. Really stressful for me before a serious deadline. I couldn't even reach the solver.

pgl posted this 13 October 2017

No problems. I can understand your frustration. I don't think this is a Windows 10 issue, rather it is case of getting our applications to support these additional characters. Our development team are aware and are looking into this as a future potential enhancement.  

Eline posted this 02 December 2017

I have the same problem.  Name of my user account is correct, only letters for English alphabet. I reinstalled and installed it. It doesn't work.

sohrab sardari posted this 17 January 2018

I had the same problem as yours, and that didn't get solved by changing the username of PC. the solution is very very simple:


The letters of the path of the ansys project file in your drivers should be only in english alphabet, For example : "Cprojects/heat/heat_transfer.wbpj"


José Lucas posted this 18 January 2018

I also have the same problem . Name of my user account is correct, only letters for English alphabet. I reinstalled and installed it. It doesn't work. Any solution?


sohrab sardari posted this 24 January 2018

change the path of your ansys project . ex: put it in C / Projects folder. (just make sure the path has english name)