Can't run a Text file in Mechanical APDL

  • Last Post 29 April 2019
  • Topic Is Solved
florian021 posted this 23 April 2019


I'm running Ansys Academic student 2019 R1 with Parrallels Desktop on my Macbook. 

When I try to run a text file in the working directory, a window pop up and shut down, then nothing happen. 

Is there a problem with the file, or with my set up ? 

Thank you. 

Order By: Standard | Newest | Votes
jcallery posted this 29 April 2019

Hi Florian021,

That is great news!

If you could, please mark this thread as "Is Solved"


Thank you,


  • Liked by
  • florian021
florian021 posted this 28 April 2019

It's working !

Thank you to both of you!


jcallery posted this 25 April 2019

The first screenshot also mentions (from what I can see) filetest.lock in the working directory.

Can you see if that is in the working directory, and if so, delete it?


Also could you copy and paste the contents of the black dos window (behind the error message) so that we can read the whole thing.

It looks like there is a mention of an environment variable as well.


Thank you,


tsiriaks posted this 24 April 2019

In the MAPDL Launcher, go to High Performance tab, then make GPU is set to 'none' . Also, try changing from Use Distributed Computing (DMP) to Use Shared-Memory Parallel (SMP)



florian021 posted this 24 April 2019

Still doesn't work.. Maybe the problem comes from the files ? 

tsiriaks posted this 24 April 2019

What if you run the software with 'run as admin' ?

If that works, you have permissions issue, somewhere.



florian021 posted this 24 April 2019

The command has opened the launcher, but the problem is still the same. 

Here is a screenshot of the error and a screenshot of the working directory : 


tsiriaks posted this 24 April 2019

What is your working directory set to ?

Try open CMD Prompt, then issue the following commands

set PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem


Does this work ?



florian021 posted this 23 April 2019

I tried with 2 txt files (in the same folder).

The APDL launcher works correctly but the "Mechanical APDL"  doesn't work (Can't open it)

Here is a screenshot.

Thank you! 

Ps: it is windows 7 

jcallery posted this 23 April 2019

Hi Florian021

Can you post a screenshot of the window that pops up before it disappears?

Does this happen with all files you try to run or just this one?

Does the APDL launcher work correctly?


Thank you,