Causes of zero values in post processing?

  • 48 Views
  • Last Post 01 May 2019
  • Topic Is Solved
Matt17 posted this 30 April 2019

Hi,

Having applied loads as line pressures and solved the model ANSYS returns the "Solution is done" message. When I view the outputs in general post processing - looking at displacements, reactions and stresses - all values are 0. Is there an error I am making for the load (1430N/m2) to not be recognised? Or is it another error I am making? 

 

Thanks,

Matt

Order By: Standard | Newest | Votes
peteroznewman posted this 30 April 2019

Matt, do you have Beams?  You have to use the Beam Tool to look at stress in the beam.

  • Liked by
  • Matt17
Matt17 posted this 30 April 2019

Hi Peter,

I've assigned my beams as RHS 120x90mm. There are 50+ with pressures of 1.43kN/m2. They carry the line load to a central keel section which is a shell element (I'm trying to design a keel for a ship display). 

I think I may be missing something in how the beams which sit on top of the keel transfer their loads to the keel section below them. So far as I can see the geometry is ok. I have attached a screenshot to try to explain myself better. The keel is supported under the keel where a rib is located for now.

Thanks.

 

rwoolhou posted this 01 May 2019

Not knowing much about Mech, but having a good understanding of how boats are built....  

rwoolhou posted this 01 May 2019

How have you defined the contact between the ribs & keel? If you check the position (and gravity) can the stringers hold the ribs in such a way that they don't actually touch the keel? 

  • Liked by
  • Matt17
Matt17 posted this 01 May 2019

The error was regarding my loading as a pressure on a line rather than a load on a beam. I'm now getting results. Thanks for all the advice and comments.

Close