Cell Zone condition is not showing and wall does not show system coupling option

  • 57 Views
  • Last Post 2 weeks ago
  • Topic Is Solved
lightyagami posted this 3 weeks ago

I have successfully ran the simulation of spiral plate heat exchanger. Now I am trying to run the simulation for 2D case. I have created required geometry Design Modeler and Spaceclaim. When I create my geometry in Design Modeler, in cell zone condition it is showing contact regions and I can't seem to apply system coupling option to wall.

In case I create my geometry in Spaceclaim I get folloeing errors:

 

Any idea how to solve this ?

 

 

Order By: Standard | Newest | Votes
Kremella posted this 3 weeks ago

Hello,

As you probably are aware, the System Coupling option shows up with you explicitly attach your Fluent simulation to an additional module 'System Coupling' in Ansys WorkBench. It gives you a way to attach either temperature or displacement loads to your Fluent simulation. Just wanted to check with you to see if you have done that. Please see the video below to understand if you have taken all the necessary steps to enable 'System Coupling' in WorkBench and Fluent.

Regarding discrepancies in the number of cell and boundary zones from Design Modeler and SpaceClaim, were you able to apply 'Share Topology' action to your geometry in both cases? Did you see any error messages in SpaceClaim when you perform the 'Check Geometry' tasks? Also, did you mesh the geometry in Ansys Meshing? Did you create the necessary 'Named Selections' there?

Thank you.

Best,
Karthik

lightyagami posted this 3 weeks ago

I use system coupling option when there is heat transfer between two walls or wall and fluid and generally it was available when I was doing 3D simulation. When I use share topology option in Design Modeler case, some faces are missing. When I use share topology option with SpaceClaim , system coupling and thermal coupling option are showing but still I can't get cell zone condition which I have assigned. I have meshed geometry in ANSYS meshing and I created necessary Named Selection there. In 'Check Geometry' option there were no problems found.

Kremella posted this 3 weeks ago

Hello,

System Coupling requires 3D meshes and cannot exist with 2D mesh. Please refer to the following section of the Users guide to understand this better.

https://ansyshelp.ansys.com/account/secured?returnurl=/Views/Secured/corp/v201/en/flu_ug/flu_wb_sec_wb_syscoup_capabilities.html

If you are unable to open the User's guide, please take a look at the following link.

https://studentcommunity.ansys.com/thread/how-to-access-the-ansys-online-help/

If you are looking to transfer heat from between two solids or a solid and a fluid, please ensure shared topology is applied properly. This should create a wall and wall-shadow. You should be able to use the 'Coupled wall' in Fluent to model these scenarios. Please refer to the Fluent User Guide for more details.

I hope this helps answer your question.

Thank you.

Best Regards,
Karthik

kkanade posted this 3 weeks ago

Share topology is used to get conformal mesh between different volumes. 

Please check

When you use share topology between two volumes, you will get single face between two volumes. This face is shared by two volumes. So this common face will have cells on both sides. 

If you do not use share topology between two volumes then you will get two faces at the connection. Each volume will have one face. Now as volume ends here, it will have cells only on one side. Meshing identifies the faces which are at the same location and creates contact regions. These contact regions can be used for defining interfaces and use it for non conformal mesh. 

Please check the documentation for more info about share topo, conformal and non conformal mesh. 

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

lightyagami posted this 3 weeks ago

Thank You, I have figured out how to use shared topology. If I use share topology option I am getting coupled option for wall in Boundary Condition but I am still not getting my named cell zone condition in ANSYS Fluent.

 

kkanade posted this 3 weeks ago

Glad that you figured it out. 

Can you please mark this as 'Is Solution' to help others on community. 

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

lightyagami posted this 3 weeks ago

Kremella posted this 3 weeks ago

Hello,

In order to get your proper cell zone names, please create a Named Selection for your 'Volume' and not just for the boundaries. For example, if all the volumes in your geometry are part of the same single fluid, please go ahead and provide a named selection to this volume - let's call it 'Fluid'. Instead of seeing different parts under cell-zone in Fluent, you will see the name 'fluid' here.

Please note that material properties are added at the cell zone level. So, if you have multiple solids in your computational domain, please create separate named selections for them. This will allow you to add material properties later in Fluent appropriately.

Thank you.

Best Regards,

Karthik  

lightyagami posted this 3 weeks ago

I have done exactly like this and still it is not showing in ansys Fluent.

lightyagami posted this 3 weeks ago

I have already figured about meshing problem and thermal coupling option. The only remaining problem I have is Cell Zone Condition. As you have pointed out I am exactly doing that but I am still getting contact regions in cell zone condition.

Kremella posted this 3 weeks ago

Hello,

Are you able to get at least one of your named selections as cell zones? Could you please share a side by side comparison of screenshots from Meshing and Fluent so we are able to clearly see the issue?

Thanks.

Best,
Karthik

lightyagami posted this 3 weeks ago

 

 

 

kkanade posted this 3 weeks ago

Did you give named selection to edges or faces or bodies? 

also make sure that you have share topology done to get conformal mesh. 

Also give named selection bodies in meshing. You can give single named selection to more than one body.

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

lightyagami posted this 2 weeks ago

For Cell Zone I have given name to bodies and for Inlet and Outlet I have given name to edges. I have made sure to use Share Topology with merge option in SpaceClaim. 

kkanade posted this 2 weeks ago

please run a test. reduce the problem size to identify issue.  

keep only two bodies in meshing. suppress everything else. 

then post images of meshing and fluent. 

this is give more idea about connected mesh and bodies. 

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

lightyagami posted this 2 weeks ago

I think fluent was automatically creating contact region into cell zone. As I only need wall coupling for my analysis I disabled the contact region and it works fine for me. I don't know if this is the solution or not but it worked for me and I got same result as my 3D simulation.

kkanade posted this 2 weeks ago

Glad to hear that it solved your issue. 

Please mark this as 'is solution' to help others on community. 

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

Close