CFX-POST not opening on remote desktop

  • Last Post 30 March 2020
Arachnid1473 posted this 28 March 2020


Because of the virus outbreak, I like many others am having to work from home. As such, I have been using remote desktop to access workbench, and was previously having trouble with a black screen in the pre and post visualisers. This was solved (for pre at least) by setting an environment variable as described in a previous post.

Now when I try and open post, I'm greeted with a window saying "Application was terminated before command could be sent" and a string of error codes that can be seen below. I have tried looking online for assistance, however none have been of any help, nor do they have the same error codes as I do, and the university IT department haven'e gotten back to me either. I would really appreciate some help as my deadline is growing ever closer.

I have attached a txt file of the error codes due to an issue with posting this question




Attached Files

Order By: Standard | Newest | Votes
rwoolhou posted this 30 March 2020

Staff are not permitted to open/download files so please post the information so we can see it. 

Arachnid1473 posted this 30 March 2020

Ok here they are, cheers

Error Codes: 


System.InvalidOperationException: Application has terminated before command could be sent.


   at Ansys.CFX.Foundation.App.CUEApplicationProxy.SendCmd(String code, String data, Int32 maxWait, Boolean ignoreCUEErrorDuringSendCmd)


   at Ansys.CFX.Foundation.App.CUEApplicationProxy.StartCommandBlock(Int32 timeout)


   at Ansys.CFX.Foundation.App.CUEApplicationProxy.CommandBlock(Int32 timeout)


   at Ansys.CFX.CFDPost.Data.CFDResultsSource.LoadEditorData(IFullContext context, Boolean interactive, Boolean dedicated)


   at Ansys.CFX.Foundation.Data.CUESourceDataObject.Edit(IFullContext context, Boolean interactive)


   at Ansys.Core.Commands.Concurrency.CommandWorkUnit.executeInContext(CommandContext subContext, IExecutionEngineCallback tracer)


   at Ansys.Core.Commands.Concurrency.BaseWorkUnit.doExecute(IExecutionEngineCallback executionEngine, CommandContext subContext)


   at Ansys.Core.Commands.Concurrency.BaseWorkUnit.Execute(IExecutionEngineCallback executionEngine, Boolean dontCatchExceptions)


--- Ansys.Core.Commands.CommandFailedException: Application has terminated before command could be sent.


CommandName: CFX.EditResultsAnalysis(Container="Results")


   at Ansys.Core.Commands.CommandAsyncResult.RethrowFailureException(Exception e)


   at Ansys.Core.Commands.CommandAsyncResult.Wait(Int32 milliSecondsTimeout, Boolean exitContext)


   at Ansys.CFX.CFDPost.Commands.EditResultsAnalysisCommand.InvokeAndWait(IProtectedContext context, DataContainerReference Container, Boolean Interactive)


   at Ansys.CFX.CFDPost.Commands.EditResultsAnalysisGui.Invoke(GuiOperationContext context)


   at Ansys.UI.GuiOperationContext.Invoke(GuiOperationMetaData operationData)


   at Ansys.UI.UIManager.InvokeOperationCore(String pseudoname, OperationDelegate callback, Boolean allowOSMessages, Boolean coreTransaction, Boolean deferredRefreshOnly)