Configuring from 2 Core to 4 Core Processor for Ansys 18.2

  • 13K Views
  • Last Post 14 August 2019
NireshBehari posted this 23 November 2017

Hi

I have a quad core HP Spectre and would like to make the solution processing time to be faster. How do I go about resetting the number of processors from 2 to 4?

 

regards

Niresh

 

Order By: Standard | Newest | Votes
peteroznewman posted this 23 November 2017

In Mechanical, Tools, Solve Process Settings..., My Computer, Advanced...

Though you are in a particular model, it is a setting for the computer, not just the model you are in, so it will persist for all other models.

You can repeat on My Computer, Background if you submit for Background solve

NireshBehari posted this 23 November 2017

Many thanks

I went to Tools--->Mechanical --->and adjusted the cores to 4

I also went to Mechanical ADL and did the same

I could not find "My Computer, Background"

I also don't see "Advanced Properties"

Remember I downloaded version 18.2

 

peteroznewman posted this 24 November 2017

You don't see a list like this in Mechanical, Tools, Solve Process Settings?

NireshBehari posted this 24 November 2017

Hi Peter

No I am trying to find that window, which you are describing 

i need to go to Tools----> Options---->Mechanical------>and then adjust the number of cores

can you please make a print screen of the Windows prior to getting to Solve Process Settings, since I cannot find that window?

And write a few more steps for me.....just to be sure

many thanks

Niresh

 

 

peteroznewman posted this 24 November 2017

Hi Niresh, here are the screen snaps from start to finish. You first have to open any model in Mechanical.

Click Advanced...

Select My Computer, Background

Click Advanced...

Regards,
Peter

guimilan posted this 06 August 2019

Hi Peter, I'm having some issue running Mechanical on multiple cores as well.

I'm running it on a cluster and if I got it right, when I set the number of cores from Tool > Solve Process Settings > Advanced..., that setting is saved for the computer I'm using at the moment of the modify, not for the specific workbench project, so if I import the file in a different machine, the setting will return to its default value (2), correct?

I prepare the file for the simulation on my laptop, then load it on the cluster, where simulations run only on 2 cores. I tried also to set the number of cores as described in this link https://www.sharcnet.ca/Software/Ansys/16.2.3/en-us/help/ans_dan/Hlp_G_ADVPARA_1.html, but with no luck. Do you have any suggestion I could try?

Best regards

peteroznewman posted this 14 August 2019

@guimilan,

It's best for you to open a New Discussion so you are notified of replies. The original poster of this discussion is going to get a notification instead of you.

If you move a workbench archive to a different computer, that computer will have a setting for number of cores, it will not automatically default to 2 cores.

Here is an old thread on how to submit to a linux cluster.

I would add that there is a flag on the command line -np 8 that says how many processors to use, in this example, it is 8 cores.

/home/ANSYS Inc/v170/ansys/bin/Linux64/ansys170 -b -i input.dat -o solve.out -np 8

Close