Contact Detection in CFD Post

  • Last Post 18 December 2018
  • Topic Is Solved
RD2016 posted this 04 December 2018

Hey guys, I got a fun one for you today.

Without getting into the particulars of my simulation, I'm modeling a valve that is slowly being closed over time. The type of valve doesn't necessarily matter in this context, but what is important is how I'm modeling closure of the valve. Essentially, I'm using Fluent's built-in contact detection feature, found in the Dynamic Meshing Tab:

I've set up my proximity threshold appropriately, and have it set up in the Flow Controls that once the surfaces are within the threshold value, a new zone will be created. This zone will be set to "porous" and act as a way to impede flow, simulating "contact" (paper Fluid-Structure Interaction Simulation of Prosthetic Aortic Valves: Comparison
between Immersed Boundary and Arbitrary Lagrangian-Eulerian Techniques for the Mesh Representation).

I've got the feature working really well, the problems arise when I try to view the results in CFD Post. It immediately crashes with the error message "ERROR Boundary <the name of the boundary that was created> is not found". At first, I thought this was due to something weird going with my final result, so I tried loading in the data set immediately before it. Still same error message. Then, I loaded in the data immediately before the valve surfaces went below the threshold value (so Contact Detection has not made the zone yet), and they loaded in okay. Thinking that this might be due to the creation of a new zone mid-simulation, I divided my results into two separate folders: one pre-contact detection, and one post-detection (note, this does not mean that I turned contact detection on mid-simulation, I enabled it at the beginning, and let the simulation run normally).

This is where it gets weird: CFD Post will not load the second dataset. The same error message keeps popping up. I can load individual result files, but I cannot load two consecutive files together.

I think this has something to do with the fact that contact detection is changing the contact zone from one time step to the next, meaning that the boundary is continually changing. This might explain why CFD Post is having such a hard time reading the file in.

So, now my question. Does anyone know a workaround for this? I would hate to try and post process in Fluent, and have a ton of experience in CFD Post.

  • Liked by
  • zjuv9021
Order By: Standard | Newest | Votes
kkanade posted this 05 December 2018

which version you are using? can you get latest version 19.2. 

are you using any udf?

can insert some zoomed in images of the set up

RD2016 posted this 05 December 2018

I'm using 19.2. No, I'm not utilizing any UDF for the creation of the new porous zone, as ANSYS has does so automatically since the release of 18.0 (at least, according to this

I'd be happy to provide am image or two of what I'm working with. I'll include an image of the point immediately before, and after the creation of the zone, but what else would you like, specifically?



Attached Files

kkanade posted this 07 December 2018

i could reproduce the error on a simple test case. 

let me work on it and will get back to you 

kkanade posted this 10 December 2018

meanwhile can you please use post processing options available in fluent under postprocessing tab. 

RD2016 posted this 17 December 2018

Just checking in to see if anything has come of this thread.

kkanade posted this 18 December 2018


defect is already logged and developer will be working on it. it will be fixed in R20 or later.. 

till then you will need to use post processing in Fluent. 

As defect is logged and final way is to use post processing in Fluent, can you please mark this as 'is solution' to help others on forum.