Convergence issue

  • 630 Views
  • Last Post 23 December 2019
  • Topic Is Solved
Ozan. posted this 21 December 2019

Hello,

As i know, if the criterion graph would be the above of the value graph, substep will converge and analysis move on. In my analysis everything seems okay about graph side but substeps not converge.

I have two similar cases. Only differences between them is contact detection types. In the both cases i used face-to-face (both solids) frictional contact. Geometrically two parts are coincident due to contact faces. First i tried turn on Adjust-to-touch option. But when i solved the contact tool, i observed the surfaces is mostly sliding not sticking even if the faces are geometrically coincident.

Then i tried to change Adjust-to-touch option to Add-offset-no-ramping and the offset value is equal to e-10. Detection type of the frictional contact which i used, were stayed program controlled. I assume program controlled option is prioritize the Gauss-point method. My case just solved. 

And in my other case, i used the same model as i mentioned above. I just changed the detection type of the inital contact. I mean Interface Treatment was set to Adjust to touch and Detection method was set to Nodal-Normal to Target. In this case i'm receiving a probem that i mentioned at the beginning. I'm going to share the screenshots about the force-disp-moment graphs during the solution.

Why is this happening ? How could i solve ?

Force Graph

Displacement Graph

Moment Graph

 

 

 

Order By: Standard | Newest | Votes
Ozan. posted this 21 December 2019

I forgot specify the analysis type. I'm working on Static Structural

peteroznewman posted this 21 December 2019

There is more than just Force to converge, there is also Displacement and you can change which graph to plot. It may be that Displacement has not converged. For shell elements there is also Moment convergence.

Under the Solution Information folder, the Newton-Raphson Force plots set to 5, not 0. Restart the solution, or just clear the solution and Solve. When the solver fails to converge, there will be 5 plots to look at. The maximum on those plots indicates the elements that have not converged. The corrective action is to remesh with smaller elements at that location.

It doesn't matter much how you closed an initial small gap, either with Adjust to Touch or an Offset. The purpose is to get the Initial Contact Status closed so the solver gets a first substep converged. It is unlikely to have any effect on whether the solution makes it to the end of the last loadstep.

Ozan. posted this 22 December 2019

Hi Peter,

First of all i'm thankfull for the quick response. I couldn't get what you tell at the first paragraph. Because i already shared the images which is belong to Force-Displacement and Moment's graph. And according to solver output i observed all of the values(force-disp-moment) are converged. I can share another images which can show the solver output if needed. But as i mentioned above substeps not converging and my analysis not solving even the values are converge. Why is that happeninng ? 

I already turned on the Newton-Raphson Force and set the value to 2. I'm going to try corrective action which you have told me at the second paragraph.

Please correct me if I'm wrong. So are you saying we are using Adjust-to-touch or Add-offset-No-Ramp. options for the initial situation ? After initial timesteps both options does not effect to the last loadstep ?

 

peteroznewman posted this 22 December 2019

Hi Ozan,

Ah, now I see you already looked at the other graphs, sorry I didn't notice.  If all the convergence criteria are met, then the next substep should begin. I don't know why that isn't happening. If you rename solve.out to solve.txt you can attach it to your reply, or attach a project archive .wbpz file.

The geometric corrections in the contact definition are applied before the solver starts and are constant throughout the simulation. They are sometimes needed to get the initial substep to converge.

 

Ozan. posted this 23 December 2019

Hi Peter,

Sorry for late answer due to timezone differences. I will attach the solve.txt file sadly i'm not able to share arhcive file.

May i ask an additional question ? May i use surface treatment as Add-offset-No-Ramp option and set the offset value to very very small digit such as e-10mm(or closer value to 0) against adjust-to-touch. Will i get the similar or same results ? or should i see any differences regarding to stress or displacement values ?

Attached Files

peteroznewman posted this 23 December 2019

Hi Ozan,

Reading the solve.out explains what has not converged, 6 joints, even though displacement, force and moment have all converged.

    EQUIL ITER  22 COMPLETED.  NEW TRIANG MATRIX.  MAX DOF INC= -0.2106E-02
     DISP CONVERGENCE VALUE   =  0.1598E-03  CRITERION=  0.5488     <<< CONVERGED
     LINE SEARCH PARAMETER =  0.7586E-01 SCALED MAX DOF INC = -0.1598E-03
     CONSTRAINT CONDITIONS ARE NOT SATISFIED FOR      6 JOINT ELEMENTS WITH LAG MULT OPTION
     FORCE CONVERGENCE VALUE  =   341.6      CRITERION=  0.3653E+05 <<< CONVERGED
     MOMENT CONVERGENCE VALUE =  0.1066E+06  CRITERION=  0.4750E+06 <<< CONVERGED
    Writing NEWTON-RAPHSON residual forces to file: file.nr002

I don't know how to list the joints that have not converged. Maybe one of the ANSYS staff here can answer that question.

I have had the experience of having a model that didn't converge because I had a joint with entities scoped too distant from the joint coordinate system. Your model has a lot of joints so you really need a method to list the joints that have not converged. Ask your local ANSYS support this question.

I also see that you are running shared memory parallel. You should try to run Distributed ANSYS instead. It is just a checkbox on the Analysis Process Settings, but it may result in a reduction in solve time.

If the Contact Tool shows a gap of 5e-10 and you add an offset-No-Ramp of 6e-10, that will close the gap.  If there is no gap, adding 6e-10 is unlikely to have any effect later in the simulation.

 

Ozan. posted this 23 December 2019

Hi Peter,

I'm going to work on what you have mentioned at first paragraph and I will inform you for sure.

I have already tried to run Distributed ANSYS. But I had some problems due to memory capacity. So actually that's why I'm running shared memory parallel.

About the last paragraph which you have told me, at the initial time the contact surfaces(solid faces) are geometrically coincident(no gap). When i checked the contact tool I observed surfaces not sticking but mostly sliding while I use Adjust-to-touch surface treatment option. I just want to remove this problem and tried to use Add-offset-No-Ramp. surface treatment option. But I thought this might cause unwanted stresses due to initial penetration. For this reason I just created another simple dummy model. I just set the offset value very very small, such as 1e-11. Afterall I checked the results and observed stresses are similar or equal in both cases. But I just want to ask the path that I followed was logical ? or that approach was all wrong ?

peteroznewman posted this 23 December 2019

I also see 69 times, a warning like this:

 *WARNING*: No MPC equations were built for the rigid constraint surface 
 identified by real constant set 707 due to overconstraint detection logic.  Please check your model carefully.

That is a lot of overconstraint warnings. Can you modify your model to reduce the number of these conditions?

peteroznewman posted this 23 December 2019

I observed surfaces not sticking but mostly sliding while I use Adjust-to-touch surface treatment option. I just want to remove this problem

If you want a surface to stick and not slide, then use a Rough Contact, that doesn't slide if it is touching.

Making 1e-10 tweaks to contact offsets does nothing to prevent sliding and has no practical effect on stress.

Ozan. posted this 23 December 2019

Peter I'm appreciate for your help. I'm going to work on the model regarding to your suggestions.

Close