Creating only surface mesh on midsurface

  • Last Post 04 November 2017
  • Topic Is Solved
arct posted this 03 November 2017

Hello everyone

I am trying to create simulation of a hydraulic cylinder. I created a midsurface in DesignModeler from Inventor part, and next solve the problem in Mechanical. First, I tried to make 2D analysis but i get an error

PlugIn Error: No valid bodies found for 2D Analysis in the folowing parts:

When I create 3D mesh, i get also volume mesh. So my question is: is it possible to create only a surface mesh, on this cylinder midsurface?

Hope I explained this right, I'm still learning FEM.

Order By: Standard | Newest | Votes
peteroznewman posted this 04 November 2017

Is this what you want?

It came from a midsurface body in my CAD system that looked like this:

That came from a solid cylinder that looked like this:

These are all 3D objects. I think you are using the term 2D when you mean a surface body that is covered with a shell mesh.

ANSYS reserves the term 2D analysis for "flat" geometry that only exists in the X-Y plane of the CAD system. Don't set the Geometry type to 2D if what you want to import is a 3D object.

Hope that helps.

arct posted this 04 November 2017

Is this what you want?

Yes, this mesh is exactly what I need. The problem is, as I said in the previous post, that in 3D I get also volume mesh.

Volume mesh on a cylinder


How can i get rid of it?


And by the way, I tried to create surface (not solid body) in Inventor, and then import that geometry to Mechanical, but I got an error that Mechanical did not detect any volume.

peteroznewman posted this 04 November 2017

I can check Thick Shells and Beam in the View menu...

to make my shell mesh look like this:

This is just a display setting, they are still shell elements, not solid elements.

If you uncheck Thick Shells and Beams in the View menu, then you will get what you want, if you have a surface body.

You can tell if you have a surface body by looking at the Outline. In the example below, I imported both the solid and the surface body, and suppressed the solid. You can see that the surface body was assigned a thickness of 5 mm.

If you want to import the surface body directly from Inventor (if you have the license to do this) go to Workbench and click on the Geometry item in the System block. The Properties panel is on the right side of the screen. Set the Mixed Import Resolution to Solid and Surface at line 29.

If you created the midsurface in DesignModeler, then you don't have to set this.

Hope this helps.


  • Liked by
  • arct
arct posted this 04 November 2017

Thank you very much! That's what I need.