Deleting Cells by using Separate Cells with Mark Register

  • 45 Views
  • Last Post 14 June 2019
  • Topic Is Solved
vidyadhar posted this 10 June 2019

Hello,

I have performed VOF simulation to obtain a liquid-vapor interface based on contact angle. I have used tetrahedral cells.

Now I want to remove the vapor cells from the domain to perform further analysis only on the liquid domain.

I tried: Separating cells by Mark (Adaptation Register) and then deleting them.

But I am getting the following errors saying deleting is not possible:

Warning: zone 2 is a degenerate face zone

 

Warning: zone 5 is a degenerate face zone

 

Warning: Cell zone 32 is not deleted because of the degenerate face zones

 

I have marked the cells based on Liquid Volume fraction values between 0.01 and 1. (Iso-value Adaption).

The cells got separated (Separate --> cells) but deletion was not possible as shown in the Warning messages above.

 

When I converted cells into polyhedra before doing the VOF simulation, deletion was possible without any warning messages as above.

 

May I get some help in solving this problem.

Thanks in advance!

vidyadhar

Order By: Standard | Newest | Votes
Kalyan Goparaju posted this 10 June 2019

Hello Vidyadhar,

You may be able to get around the warnings by slitting the problematic faces before deleting the cell zone. As an example, from your output, zone-2 and zone-5 are the problematic face zones, you can slit these zones using the command

/mesh/modify-zones/slit-face-zone

Once these faces are slit, you should be able to either delete or deactivate the separated cell zone. 

Thanks, 

Kalyan

  • Liked by
  • vidyadhar
vidyadhar posted this 10 June 2019

Hello Kalyan,

After Marking cells and Separating Cells, I have done as below:

> /mesh/modify-zones/slit-face-zone

Face zone id/name [] 2

 

Slitting wall zone 2 into a coupled wall.

creating interior-fluid:002-shadow

> /mesh/modify-zones/slit-face-zone

Face zone id/name [] 5

 

Slitting wall zone 5 into a coupled wall.

creating interior-fluid:005-shadow

 

Even then the same problem persists and I can not delete the cell zone!

 

Thanks for the suggestion and hoping for more!

Regards,

vidyadhar

 

Kalyan Goparaju posted this 10 June 2019

Hi Vidyadhar, 

Does deactivate work instead of delete? 

Thanks, 

Kalyan

vidyadhar posted this 11 June 2019

Hello Kalyan,

No, Even 'deactivate' did not work.

 

Should I have to separate--> faces also along with separate-->cells?

Thanks & Regards,

Vidyadhar

rwoolhou posted this 11 June 2019

Plot the marked zone, you may be trying to create isolated lumps of fluid. 

vidyadhar posted this 11 June 2019

Hello rwoolhou,

How to plot the marked zone. Can you please help me.

 

Thanks & Regards,

Vidyadhar

rwoolhou posted this 11 June 2019

There should be a Display option in the register panel or Manage register panel. 

abenhadj posted this 11 June 2019

Can you just display this problematic zone (the zone you want to display)? 

Best regards,

Amine

vidyadhar posted this 11 June 2019

Hello rwoolhou,

Yes, it displays the marked zone.

It displays the fluid region containing the selected iso-values.

For example, I have selected iso-values of volume fraction of secondary phase lying inside 0.5 and 1. If I display the register, it shows half of the volume of my domain.

After marking, I have done separate--> cells and tried to delete/deactivate certain fluid cell zones. But, it was not possible due to the formation of degenerate face zones.

Is there something to deal with grid size?

Thanks & Regards,

Vidyadhar

vidyadhar posted this 11 June 2019

  

vidyadhar posted this 11 June 2019

Hello rwoolhou and abenhadj,

The first figure shows the curved solid with fluid occupying to its right side.

The second figure shows the Adaptation register marked with iso-values of secondary phase lying between 0.5 and 1. i.e., it forms the lower part of schematic.

After separation of cells by this register, the output is given as below:

------------------------------------------------------------------------------------------

Separates zone 15 into two zones, with 17026 and 22554 cells.

Separates zone 16 into 4 zones.

All faces marked on thread, 8

All faces marked on thread, 5

All faces marked on thread, 2

Separates zone 18 into 2 zones.

All faces marked on thread, 11

No faces marked on thread, 25

All faces marked on thread, 26

All faces marked on thread, 21

No faces marked on thread, 22

Separates zone 23 into 2 zones.

All faces marked on thread, 29

Moved 22554 cells from cell zone 15 to zone 32.

 

Updating new zone information...

created new zone fluid:032 from fluid

created new zone symmetry-fluid:029 from symmetry-fluid

created new zone junction_solid_fluid-shadow:026 from junction_solid_fluid-shadow

created new zone junction_solid_fluid:011 from junction_solid_fluid

created new zone interior-fluid:008 from interior-fluid

created new zone interior-fluid:005 from interior-fluid

created new zone interior-fluid:002 from interior-fluid

done.

----------------------------------------------------------------------------------------------------

vidyadhar posted this 11 June 2019

The first two images are so formed interior-fluid:002 (interior, Id=2), interior-fluid:005 (interior, Id=5) and the third image is the combination of the first two along with adjacent solid-fluid wall.

 

abenhadj posted this 11 June 2019

Can you check your mesh now? It is possible that the mesh got corrupt after separation of the cells!

Best regards,

Amine

  • Liked by
  • vidyadhar
vidyadhar posted this 11 June 2019

Hello Amine,

The output from Fluent shows MeshCheck is passed. Quality was the same as before.

vidyadhar posted this 12 June 2019

Hello Amine,

The mesh check was passed after separation of cells. But, if I slit the face zones 2 and 5 then the face zones which were interior are converted as walls. And Now, If I perform MeshCheck, there are WARNINGS and mesh check is FAILED !!!

 

Thanks & Regards,

Vidyadhar

vidyadhar posted this 12 June 2019

> /mesh/modify-zones/slit-face-zone

 

Face zone id/name [] 2

 

 

Slitting wall zone 2 into a coupled wall.

 

creating interior-fluid:002-shadow

 

> /mesh/modify-zones/slit-face-zone

 

Face zone id/name [] 5

 

 

Slitting wall zone 5 into a coupled wall.

 

creating interior-fluid:005-shadow

 

 

Domain Extents:

 

x-coordinate: min (m) = 0.000000e+00, max (m) = 1.372700e-04

 

y-coordinate: min (m) = -1.287266e-20, max (m) = 2.000000e-04

 

z-coordinate: min (m) = 0.000000e+00, max (m) = 1.372700e-04

 

Volume statistics:

 

minimum volume (m3): 3.731774e-18

 

maximum volume (m3): 9.089606e-16

 

total volume (m3): 3.768611e-12

 

Face area statistics:

 

minimum face area (m2): 1.756546e-12

 

maximum face area (m2): 2.112003e-10

 

Checking mesh.......

 

WARNING: 22 cell(s) have only wall faces......

 

WARNING: 4 pair(s) of adjacent faces with different orientation on zone 35.

 

WARNING: 4 pair(s) of adjacent faces with different orientation on zone 2.

 

WARNING: 4 pair(s) of adjacent faces with different orientation on zone 38.

 

WARNING: 4 pair(s) of adjacent faces with different orientation on zone 5................

 

Done.

 

 

WARNING: Mesh check failed.

 

 

 

To get more detailed information about the mesh check failure

 

increase the mesh check verbosity via the TUI command

 

/mesh/check-verbosity.

rwoolhou posted this 12 June 2019

OK, it's created isolated cells which you need to remove. Read up on the "Separate Mesh" options in Fluent, I think it's region that'll get those. Not sure about the others but hopefully getting rid of the 22 isolated cells will help fix some of those. 

  • Liked by
  • vidyadhar
vidyadhar posted this 12 June 2019

Hello rwoolhou,

Thank you for the comments.

In the meanwhile, I have modified my mesh by using default sizing parameters for body meshing and face meshing and 'Automatic Method'. (Earlier, I have imposed certain sizes, 'Hard' behavior and Tetrahedron for the Method while Meshing).

Now majority of the cells are hexahedrals. Orthogonal quality and skewness are improved.

Now, I am able to delete the cell zone after separation by carefully selecting 'Adaptation Register' (Iso values of secondary phase volume fraction). However, for certain ranges of volume fraction, still I am facing the issue of degenerated face zones.

Anyway, I hope I could proceed forward. Thank you all for the time and suggestions.

Regards,

vidyadhar

abenhadj posted this 14 June 2019

Good to know to see u progressing please mark this then as Is Solved.

Best regards,

Amine

Close