Desginpoints in Ansys 18.2 workbench got stuck at the stage of updating model in static structural

  • Last Post 12 May 2018
  • Topic Is Solved
Patrickhe posted this 08 January 2018

Hello guys,

I updated Ansys to 18.2 a month ago. When I transferred my model built in 18.1 to 18.2 and did the design points update, it always got stuck forever at the stage of updating model in static structural of 50% like the picture below.

I tried this model in 18.1 and it worked just fine which took about 2 mins to solve each design point.

I tried clearing the regedit and reinstalling both 18.1 and 18.2 which didn't work.

I tried to rebuild this model in 18.2 which didn't work.

I tried to unmark the distribute solution (picture below) in Mechanics which didn't work either.

I wonder is this a bug in 18.2 or is there something I should change in my system? I am using windows 10 pro x64.  Thanks if anyone can help solve this.

Order By: Standard | Newest | Votes
Raef.Kobeissi posted this 08 January 2018


Can you please provide additional information about the simulation.

Best Regards

Raef Kobeissi

Patrickhe posted this 08 January 2018


I used the imported CAD parameters from solidworks then set the design points in ansys. After the geometry was successfully updated the process of mechanical of updating kept running without solving. The parameters I set is like the pic below.

Do you need any other information?



peteroznewman posted this 08 January 2018

I assume you are not on the Student license, but either a Commercial or a Research license since the Solidworks CAD interface is not provided in the Student license. Fortunately, I have the Solidworks CAD interface at work and am willing to test your files if you want.

You would have to create a zip file of the Solidworks files and an Archive of the ANSYS project. Use the Attach button to add the Archive and zip file to your last post. There is a 120 MB file size limit, so work within that by splitting the Solidworks files into two or more zip files (maybe on two posts) if you exceed this value. In ANSYS, clear generated data on the mesh to reduce the size of that archive.

What version of Solidworks are you using?


Patrickhe posted this 08 January 2018


I am using Solidworks2017 and ansys 18.2 on student license. I'm not sure but I did can work with CAD parameters both in ansys 18.1 and 18.2.

Files have been attached.



peteroznewman posted this 08 January 2018

I downloaded your files and opened them on my Commercial license where I have a Solidworks CAD Interface license for ANSYS. I repaired the file pointer to point to the Solidworks part file and I confirmed that your initial model solved correctly, then I tried to Update All Design Points. I found the Progress stalls on the first CAD update (DP0 and DP1 have no change in CAD parameters) for a really long time (>10 minutes), but eventually, it did update and so did the next one (I deleted the rest of the DPs).

I am also going to get on my other laptop with ANSYS Student 18.2 and test the ability to import Solidworks files (after I install SW2017) as I did not think the SW CAD interface was included in the ANSYS Student license.

Patrickhe posted this 08 January 2018


Thanks for the quick reply!

Actually if I use the same file which can also be opened in 18.1, 18.1 version will solve in a reasonable time while for 18.2 it seems to take forever.

For me geometry update is ok but it will get stuck in the process of mechanical updating.

What really confuses me is that if i manually change the parameters, then double click to renew and enter the interface of mechanical, then click solve, it in fact works there. However, if i choose to right click on model and update, it will get stuck there.

peteroznewman posted this 08 January 2018

There is definitely a bug in ANSYS 18.2 that creates a huge delay (>30 minutes) in an update from SW through DM to Mechanical. I will create a simple model and submit that bug to my local ANSYS support people who will verify it is reproducible then forward it on to ANSYS developers. You should stay in 18.1 for now...

Patrickhe posted this 08 January 2018

All right then, thanks!

peteroznewman posted this 08 January 2018

I made a simple solid model with two Design Parameters and the Parameter Set solved without huge delays so I was unable to reproduce the problem on your files. My files are in the attached zip file if you want to try it on your system.

Attached Files

  • Liked by
  • vganore
Patrickhe posted this 08 January 2018

wow Great! Thank you!

saurabh156 posted this 04 April 2018

Hello everyone. I m running Parametric optimization on ANSYS Workbench using VisualDOC optimizer by Van der plaats. 

When the design iterations are running, they are properly simulated by ANSYS for a few iterations. But Fluent stops working after a while. It pauses the simulation. I m not sure what the problem is. Any help will be appreciated. 



saurabh156 posted this 12 May 2018

Hello Raef and Peter, 

I m really stuck at a problem. Can you please help me with it. I have posted my question above. 

Any help will be appreciated. 

Thank you.