Error from Fluent

  • 165 Views
  • Last Post 06 April 2020
ChristianWood posted this 20 March 2020

Hi,

I am currently trying to do a CFD simulation for my final year project at university, due to the corona virus at the moment, I am having to work from home. When I am trying to do the simulation, I am getting an error, I have imported my geormetry, and have made my mesh and completed setup, the same as I was doing at university, where this worked, and I have completed simulations there. The error I am getting is as follows:

Error: cx-run: can't listen on renezvous socket.
Error object: ()

Error: eval: unassigned variable
Error object: rp-3d?

version>
Error: eval: unassigned variable
Error object: rp-3d?


once this has been posted in the console of fluent, the fluent application closes itself, and I get a meesage from ansys workbench saying:

The FLUENT application failed to validate the connection.

any help or advice would be appriciated, I am not particularly well versed with this software and am self taught, so if possible, please try to keep it simple.

regards

Christian

Order By: Standard | Newest | Votes
rwoolhou posted this 20 March 2020

Is it the same geometry as before or a different one?  It's a 3d error: check the model is on the z=0 plane too if 2d and has a volume mesh if 3d. 

ChristianWood posted this 20 March 2020

The geometry is the same as the one's I've run at university, as is the mesh. 

kkanade posted this 23 March 2020

Is you geometry 2D or 3D?

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

ChristianWood posted this 23 March 2020

Yes, it's a 3D model, and I'm importing it the same way as I did before at university.

rwoolhou posted this 23 March 2020

Can you post a screen grab of the set up and all error messages. If you can, scroll up in Fluent in case there's something more diagnostic there.  

ChristianWood posted this 23 March 2020

 

I scrolled up in the console, there was no more error messages or information

rwoolhou posted this 23 March 2020

If you're running at/from home is it the same computer, or are you using a "home" PC?  Try serial and see what happens. If that works, open up the "more options" I wonder if the parallel settings are correct for your (new?) machine. 

ChristianWood posted this 23 March 2020

Yes, this is a different computer, as the ones I was using before were in the university library, I was using those computers as I was getting this error, and thought I'd get the work done there, but with this virus being around I can't work there anymore. I have just tried serial, and I'm getting the same errors.

ChristianWood posted this 23 March 2020

When fluent opens, and gives those errors in the console. I try and interact with the software, and I get the message "there is no active application"

 

kkanade posted this 24 March 2020

from meshing export .msh file for fluent. 

then try to open standalone fluent and read .msh file. use serial mode. 

please try this and let us know. 

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

kkanade posted this 24 March 2020

also try on simple flow through pipe  or similar example which will give idea if it is installation issue or mesh issue or solver issue. 

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

ChristianWood posted this 24 March 2020

In the past I have tried simple examples, such as a 2 flat plate and a 3d flat plate, and have gotten the same error both times. I am sorry for the quality of the picture, I took it at the time and don't have the saved file anymore. At the time I tried both serial and parallel, to see if it would make a difference.

kkanade posted this 26 March 2020

did you try standalone fluent? 

from meshing export .msh file for fluent. 

then try to open standalone fluent and read .msh file. use serial mode. 

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

ChristianWood posted this 26 March 2020

Sorry, I'm not sure what you mean standalone fluent, I can only access Fluent through the workbench, if I search fluent in windows, nothing comes up.

rwoolhou posted this 26 March 2020

There's not an icon in Start for some reason. Launch fluent.exe from

C:\Program Files\ANSYS Inc\v201\fluent\ntbin\win64\

You should be able to open Fluent and then read in the mesh. That'll help understand if it's the model or the solver install (or the hardware). 

ChristianWood posted this 27 March 2020

followed your instructions, had a slightly different path, mine was:
C:\program files\ansys\ansys inc\ ansys student\ v194\fluent\ntbin\win64

and once I'd opened fluent, the above error came out

kkanade posted this 30 March 2020

if you have tried a simple cube or flow in a pipe example and if it is working then it may be a installation issue. 

can you please uninstall and reinstall 2020R1. 

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

ChristianWood posted this 30 March 2020

I have now reinstalled ansys student, I believe I've done it properly, and I am now getting this error

this is from the fluent console

 

kkanade posted this 31 March 2020

this must be installation issue. I am moving this to installation and licensing category to get better response. 

 

ChristianWood posted this 31 March 2020

When I was installing the software, I got a message from my Anti Virus (bull guard) that it had quarantined some software, I looking into this and it was an ansys program, I released it, then got the above error. Does this information help?

rwoolhou posted this 31 March 2020

Possibly, can you try the install with the anti-virus turned off? 

ChristianWood posted this 01 April 2020

reinstalled the software with my anti-virus and firewall disabled, and I'm still getting the above error

tsiriaks posted this 06 April 2020

Open CMD Prompt and issue the following command

"%awp_root194%\fluent\ntbin\win64\fluent.exe" 3d -g -t0

do you get the same issue ?

If so, there is still something on the machine that prevent the socket connection. When you reinstall, did you completely delete this C:\program files\ansys  folder before installing it again ?

Close