Error occurs when attempting to save files in Workbench. Access Denied.

  • Last Post 02 February 2018
Julian posted this 19 January 2018

I installed and used the student addition Ansys 18.2 for two approximately 2 weeks. Now it is not functional.

I can no longer save any files. I receive the following error message when attempting to save. I am able to save before I open DesignModeler, but unable to save after opening DM.

Access Denied Error Message

I reinstalled 18.2 to try to resolve the issue and also tried installing 18.1. I receive the same error message with 18.1 and am unable to save any files after opening DM.

If I try to access subfolders within .test_files.backup through file explorer I also receive a message that access is denied.

Any help would be greatly appreciated.

Order By: Standard | Newest | Votes
vganore posted this 19 January 2018

Looks like editing permission is not given to the file. Try opening Workbench as "Run as Administrator". See if that helps.

Vishal Ganore,

Julian posted this 19 January 2018

Thanks for the suggestion, I tried that earlier, but unfortunately it didn't work.

I also made sure to run the setup files as administrator when installing.

Here is the error message I receive when running 18.1 as administrator after attempting to save in DM:

Error message with details

Also, FYI I'm running in Windows 10 with it's latest updates.

vganore posted this 19 January 2018

Some more suggestions:

1. Check the permissions given to folder "ANSYS". All modifying permissions to folder. 

2. Disable any antivirus and firewall.

Vishal Ganore,

Julian posted this 20 January 2018

I've tried saving to multiple locations including documents, c:\temp, etc. and none work. I adjusted security permissions for the ANSYS folder for all users to full control.

All folders on the computer have the read-only checkbox checked. After un-checking the read-only checkbox and reopening properties, it is checked again. I confirmed however that i am able to read/write within that folder. I checked another Windows 10 computer and it also had all folders with the read only checkbox checked, so I don't think that's the issue.

I turned off thee firewall and virus protection and get the same error message, so that does not appear to be the issue.

I installed 17.2 and get the same error.

I suspect that a windows update which was pushed the same day I last successfully saved an ANSYS file (12/12/17) is to blame, unless you have any other suggestions.


Julian posted this 02 February 2018

I did a repair installation of windows 10 and still get the same error message. Not sure what else I can try. Note that I installed Ansys student 18.2 on another windows 10 machine (with a full re-installation of Windows) and was able to run it successfully.