Error running ANSYS v19.0 on linux

  • Last Post 21 December 2018
Julia posted this 07 December 2018

Hello - I am running Ansys EM version 19 on a linux machine (red hat version 7.6) and it keeps aborting (below). I do not know if it is specific to the project I am running or the software. Any help is greatly appreciated! 

Order By: Standard | Newest | Votes
rwoolhou posted this 10 December 2018

Is there any additional text? Are you running on the local machine?  Have you tried with a different model or new project? 

Julia posted this 11 December 2018

Yes I am running on the local machine. There is no additional text describing the error. This has happened with a different model but it could be due to a corrupted project file(s) since I was running the simulations from a windows virtual machine. 

rwoolhou posted this 11 December 2018

If you have the project on another machine and then want to move it over to LINUX please archive the project and move that. The wbpj file holds all of the file locations etc and can become corrupt if you just copy that file & the associated project over. 

Alternatively, if you're running on/from a virtual machine has the display been passed back to the "real one"? 

  • Liked by
  • peteroznewman
Julia posted this 11 December 2018

So when I wish to move solved projects to different locations I should instead move the archived project and not the project + results? Previously, I was copying the .aedt and .aedtresults (and sometimes the .aedb) files and folders to new locations. Could this be the reason many of my project files were becoming corrupted? 

I am not sure what you mean by "has the display been passed back to the 'real one'", but I was running Windows 10 on bootcamp on a Mac. I was then submitting jobs to a cluster running linux and copying the completed project files to a shared server. However, I recently gained access to the linux machine and am hoping that solves my problems of file corruption, etc. 

rwoolhou posted this 12 December 2018

Possibly: that does tend to prevent corruption for fluids and mechanical projects. I'd missed the HFSS tag, but if the files are linked you may be confusing the code by moving the files. 

If you're running on a LINUX system it's common to sit at one machine and launch solvers remotely but pull the graphics back to the one you're sat at.  We use 

sentenv DISPLAY mybox:54

where mybox:54 is the machine ID and graphics job (it's a shared machine). 


Julia posted this 14 December 2018

Yes, that is my plan - launch the solver remotely and then pull the graphics back down. However, when I am in the AnsysEM GUI it will randomly abort, even when I start a brand new local project. 

I have core dump file but it won't let me attach it here. It just says that the application was aborted. 

Julia posted this 17 December 2018

This is another error I frequently encounter (even when the projects are not locked or open in another instance..). Do you have any advice to prevent this? 

EDB may be in use.

Would you like to claim ownership?

Yes: open with write access

No: open with read-only access

Yes/No? [Yes] :[warning] Project:RFWireless_12122018, EDB is read only. Save or AutoSave can't be performed. (3:23:40 PM  Dec 17, 2018)


Thank you again! 

rwoolhou posted this 21 December 2018

Not something I've come across: I've asked one of the HFSS team to take a look.