FLUENT 2019 R1 and FLUENT 19.2 fails to load

  • 88 Views
  • Last Post 2 weeks ago
Sayger posted this 09 November 2019

Hi,

I am having issues with fully loading ANSYS Fluent 19.2 and ANSYS 2019 R1 (through my university's academic license) on my Thinkpad P50 Laptop (i7-6820HQ CPU, Quadro M2000M GPU, Windows 10-64bit). Both Fluent versions (19.2 and 2019 R1) get stuck in loading with the following text in the console:

              Welcome to ANSYS Fluent Release 19.2

 

              Copyright 1987-2018 ANSYS, Inc. All Rights Reserved.

              Unauthorized use, distribution or duplication is prohibited.

              This product is subject to U.S. laws governing export and re-export.

              For full Legal Notice, see documentation.

 

Build Time: Aug  8 2018 134:52  Build Id: 10236  

 

 

     --------------------------------------------------------------

     This is an academic version of ANSYS FLUENT. Usage of this product

     license is limited to the terms and conditions specified in your ANSYS

     license form, additional terms section.

     --------------------------------------------------------------

Host spawning Node 0 on machine "DESKTOP-H8F2G0U" (win64).

WARNING: No cached password or password provided.

         use '-pass' or '-cache' to provide password

 

This occurs when I am setting the processing options to 'serial' or 'parallel' (with '1'+ processes and 'none' GPGPUs). I am only able to successfully load FLUENT when the processing option is set to 'parallel' with 0 processes and 'none' GPGPUs. 

When opening either of the FLUENT versions, I get a pop-up notice to approve Firewall permissions for 'mpirun', 'cx1920' (or 'cx1930), 'fl1920' (or 'fl1930') which I allow for all but am still stuck on loading. I have verified that my Firewall allows app permissions for all of the listed processes. I have tried disabling Windows Firewall and reopening FLUENT, but I run into the same issues.

I installed the same applications on another computer (Windows 10-64 bit, EPYC workstation) and I am able to successfully load FLUENT with all processing options (serial, parallel). Did not have to change any firewall settings.

Could anyone provide any assistance on how to resolve this issue? Thanks.

 

Order By: Standard | Newest | Votes
tsiriaks posted this 4 weeks ago

Aside from Firewall, can you also try turning off any virus/threat protection software ?

Sayger posted this 4 weeks ago

I tried also turning off virus/threat protection and I still have the same issues for both Fluent 19.2 and Fluent 2019 R1. The only available option to open Fluent is with the parallel processing options with 0 processes.

tsiriaks posted this 3 weeks ago

This means the systems has issue launching MPI processes. See below for the differences.

Different processes launched by serial vs parallel Fluent (Windows). Note this example is for 19.2 but it's the same for all versions.

serial

cx1920.exe

fl1920.exe

fluent.exe

fl_mpi1920.exe

true serial (parallel with 0 cores)

cx1920.exe

fl1920.exe

fluent.exe

parallel (assuming 3 cores)

cx1920.exe

fl1920.exe

fluent.exe

fl_mpi1920.exe

fl_mpi1920.exe

fl_mpi1920.exe

mpid.exe

mpirun.exe

You can see that the 'true serial' mode never touches MPI. 

The most common cause of this issue is security on the machine blocking these processes to run as it thinks that these processes are a 'threat' .

 

Sayger posted this 3 weeks ago

Thanks for the detailed list of the launched processes. 

I verified that my firewall exceptions include all of the listed processes in parallel (multi-core) Fluent, but I am still running into the same issue of not properly loading Fluent.

I am now also experiencing the same issue on my workstation which I previously had no issues with. I recently updated to Windows 10 Pro for Workstations (Version 1909). Disabling both Firewall and Virus/Threat protection does not help.

Appreciate it if you could provide any additional solutions I may try.

Sayger posted this 3 weeks ago

I should note that both my laptop and my workstation continues to be able to successfully load Fluent (19.2 and 2019 R1/19.3) in Parallel - 0 processes mode. 

 

It appears the issue is indeed with launching the MPI processes, but the problem doesn't appear to be related to Firewall and Virus/Threat protection since I've tried disabling both already. Could this problem be related to the Intel MPI?

Sayger posted this 3 weeks ago

I tried both Intel MPI and IBM MPI, but I am still running into the same Fluent loading issue.

tsiriaks posted this 3 weeks ago

Are you using any VPN tool or any tool with similar mechanism that could change your network or machine IP and/or Mac address ?

Are you connecting to both LAN and Wi-Fi at the same time ?

Also, for the security software, nowadays, they have lots of different components/tools in one suite, so you may need to make sure to try turning all of them off. If you are using Windows Defender, make sure you turn off Core Isolation as well since it's shown to cause an issue in the past (not this exact issue but still good to try) 

 

Sayger posted this 3 weeks ago

I am using Cisco AnyConnect VPN to connect to my university's engineering network to get access to my university's academic license for ANSYS. 

I am connecting to only Wi-Fi when attempting to open Fluent.

 

I verified that I have Windows Defender Firewall off, Windows Virus/Threat Protection off, and the Core Isolation off (already off by default). When opening Fluent 2019R1, it still fails to fully load and I am left with the message: "WARNING: No cached password or password provided. use '-pass' or '-cache' to provide password. I am forced to open Task Manager and kill the application. When opening Task Manager, I see only cx1930.exe, fl1930.exe, and fluent.exe; in occasional attempts, I see the Console Window Host and Qt Qtwebengineprocess also running. 

Oddly enough, if I open up a Windows 10 virtual machine using VirtualBox on the same PC and sign into the ENGR network using the AnyConnect VPN (in either the host PC or the VM), Fluent opens in parallel mode with multiple processes with no issue. 

However, I would still like to find a solution for getting Fluent to load properly in parallel mode with multiple processes using the host PC to take advantage of the total number of CPU cores.

I appreciate you still attempting to help me with this issue, Win. Hoping to determine a fix soon!

tsiriaks posted this 2 weeks ago

Now VPN is a prime suspect (or I can almost say that it's the cause of the issue) as we have seen lots of cases like this. When you are at your university, can you try connecting to your university network without using VPN , at least to confirm the thoughts ?

I don't exactly know why it works from inside your VM but I'm pretty certain the issue is with VPN messing up with some local networking required by MPI (Maybe, certain 'virtual networking' in your VM did not get affected by VPN the same way as the networking on your host) 

Close