Fluent AAS Matlab toolbox - Can' t load Journal file

  • 50 Views
  • Last Post 20 March 2019
Xabierenko posted this 13 March 2019

I'm succesfuly able to connect fluent and matlab thanks to the aas toolbox and the following commands.

orb=initialize_orb();
load_ansys_aas();

iCoFluentUnit=actfluentserver(orb,'aaS_FluentId.txt');
iFluentTuiInterpreter=iCoFluentUnit.getSchemeControllerInstance();

However, when I try to load a journal file I obtain the following error. I have tried several formats for the input text command but nothing seems to work. This are several formats I have already tried.

iFluentTuiInterpreter.doMenuCommandToString('file/read-journal Journal.jou ')
iFluentTuiInterpreter.doMenuCommandToString('file/read-journal/Journal.jou ')
iFluentTuiInterpreter.doMenuCommandToString('file read-journal Journal.jou ')
iFluentTuiInterpreter.doMenuCommandToString('file read-journal \"Journal.jou\" ')
Error using ConnectFluent (line 24) Java exception occurred: AAS_CORBA.EFluentGenericError: IDL:AAS_CORBA/EFluentGenericError:1.0 at AAS_CORBA.EFluentGenericErrorHelper.read(EFluentGenericErrorHelper.java:80) at AAS_CORBA._ICoFluentSchemeControllerStub.doMenuCommandToString(_ICoFluentSchemeControllerStub.java:126)

 

Order By: Standard | Newest | Votes
rwoolhou posted this 14 March 2019

Try /file/read-journal   the first / can be critical depending on where in the TUI you're working: it forces the command to start in the root TUI level. 

 

Xabierenko posted this 20 March 2019

Not that is not the problem. I have read somewhere that it is not possible to load a journal through MATLAB.

Close