fluent meshing mode

  • 115 Views
  • Last Post 3 weeks ago
Genf posted this 01 November 2019

Hello,

I'm using fluent meshing mode to create mesh. When I create surface mesh, I get the error message:

error: arg(3rd) out of range in substring

error object: 6

Can anyone help me to find the possible reason?

 

Thank you,

Order By: Standard | Newest | Votes
rwoolhou posted this 01 November 2019

Pictures and setting will help. Remember to post images in with the text as staff are not permitted to open/download attachments. 

Genf posted this 01 November 2019

watertight geometry workflow is used 

 

Thank you,

rwoolhou posted this 04 November 2019

I wonder if it's the Student version hitting the cell cap.  Increase the smaller cell size by a fair bit and see if it'll work. Then try and refine. You're capped at 512k cells, so if you have that many vertices I suspect you're creating too big a mesh. 

Genf posted this 04 November 2019

hi,

I increased the minimum cell size to 5, it still has this message. I'm using academic license.

I used these settings to generate mesh on my old computer using ANSYS 2019 R2, it worked.

But after I transfer the model to a new computer and use the same settings, the error message came up. The ansys version on the new computer is 2019R3.

thank you

 

rwoolhou posted this 05 November 2019

Meshing didn't change that much. Were you using Student on the old computer? Given the number of surface facets I don't see how it could work on Student. 

Genf posted this 06 November 2019

I'm using academic license on both computers. the problem may be caused by different versions of ansys. I have tried other fluent mesh files. Sometimes when I just open the mesh file and click on create surface mesh, the error message shows up:

Error: arg(3rd) out of range in substring

Error Object: 6

Error: Illegal Variant cast from bool to class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> >, data: False

Error Object: ()

 

thank you

rwoolhou posted this 06 November 2019

Teaching or research?  Also, what's the new computer & folder (full path) called?

Genf posted this 5 weeks ago

Research, 

computer name: Untaroiu-2

fluent : C:\Program Files\ANSYS Inc\v195\fluent\ntbin\win64

  

 

rwoolhou posted this 5 weeks ago

Not sure then: can you mesh a simple cube? 

Genf posted this 5 weeks ago

yes, it works with a simple cube.

rwoolhou posted this 4 weeks ago

So it's model dependent. Pick a big cell size (ie far larger than will resolve the flow features) and try again. I don't care about mesh quality, I want to see what the cell count is. 

Genf posted this 3 weeks ago

Hi, I tried different settings for a simple cube. It also has errors some time. It seems like when a local size is added, the error message comes up.

rwoolhou posted this 3 weeks ago

What's the local sizing set to? Also how big is the box?

Genf posted this 3 weeks ago

 The box is 21x21x30 mm, Local sizing: 5,

  

rwoolhou posted this 3 weeks ago

Weird. That should give you about 4-6 cells on each edge. I assume the guide "cubes" are a sensible size?

Genf posted this 3 weeks ago

Hi, what are guide cubes ?

rwoolhou posted this 3 weeks ago

The green cube (they're red on my display). They show the expected cell size, you'll typically see two sizes for a min & max. Can you turn off proximity: I wonder if you've created an impossible set of conditions for the mesh. Ie the surface mesh can't be true for both the local & surface sizing. 

Genf posted this 3 weeks ago

The proximity is turned off, but still the same message. The error occurs when reading the temporary .sf file. When I remove the local sizing, it works with the same setting under 'create surface mesh'.

If I make the local sizing on all the surfaces same as the minimum size under 'create surface mesh', What possible changes can local sizing add to the mesh? Is the local sizing information stored in .sf file ? Is it possible to view the details in .sf file ?

 

rwoolhou posted this 3 weeks ago

The sizing on the surface will be a function of the size functions and local sizing. Given it's a cube curvature is unlikely to do much, so sizing will be set by proximity. You can probably get the size function out from the tree (not the workflow) but I'll leave that for you to find: I rarely use that feature. 

Genf posted this 3 weeks ago

thank you for the explanation. The errors occurs when I transfer files to a different computer (same settings), so I doubt it might be caused by software installation.

But do you have suggestions on how to set element size on a specific surface in fluent meshing mode ?

I'm new to fluent meshing, Do you recommend to use workflow in fluent  for mesh generation ?

Thank you

rwoolhou posted this 3 weeks ago

I tend to use the new Watertight Workflow for most problems, but also don't tend to use much local sizing. In your case I think the surface sizing is conflicting with the proximity function, try 4-5 cells across the "gap" and see what happens. 

Close