Geometry editor was closed abnormally

  • Last Post 23 August 2019
saadabbas posted this 18 October 2017

I have downloaded "Ansys 18.2 (3.9 GB) Student version" to implement the FEA but unfortunately i couldn't be able to open the geometry. Every time i open it i get the error "Geometry editor was closed abnormally"


I looked for the solution but didn't get the proper answer.


Your help will be highly appreciated.





Order By: Standard | Newest | Votes
vganore posted this 18 October 2017

Looks like windows file registry issue. Could you please open Workbench by "Run as Administrator" option and see if that helps? 

Vishal Ganore,

saadabbas posted this 19 October 2017

No, it doesn't work as well .

vganore posted this 19 October 2017

Ok. You can try this. Let me know if it works.

Step 1:

Go to product installation path: C:\Program Files\ANSYS Student\v182\commonfiles\configs\winx64\config

Run as Administrator: AnsConfigSpaceClaim.exe

Step 2: Run file “regedit.exe” from windows, go to view> say "Refresh" then search for folder "SpaceClaim.AnsysSCDM.182"

Make sure that SpaceClaim path is correctly listed based on your installation area. Restart your PC and open Workbench.



Vishal Ganore,

hamzah posted this 31 October 2017

hi i have win 7 64bit with the same problem when i run the mesh on fluent model a message appear and says, the geometry editor was closed abnormally

i have tried  all the solution above  but it didn't work please help.

Jheferson_ga posted this 01 November 2017

hello. I have the same problem too, when I start a new project of Design Assessment the second step is make a geometry to work, but at the moment of start the SpaceClaim, Ansys shows that message. then I close it and can make my figure, but when came back to the Workbench... it doesn't receive the archive. 

vganore posted this 13 November 2017

Unsupported graphics card could be the problem. Could you please check whether you have ANSYS supported graphics card (NVDIA or AMD) in your system?

In the RUN command type: dxdiag , go to display and check the graphics card. 

Also, are you using any integrated graphics card?


Vishal Ganore,

vganore posted this 15 November 2017

Please review this document for ANSYS supported graphics cards.

Vishal Ganore,

asnalb posted this 15 December 2017


I am not entirely sure what the reason of this might be, but I get the same error message after installing the software on a machine with Windows 7, whereas it works totally fine on Windows 10. 

mohamed gamal posted this 18 January 2018

I did the steps above, but still have the same problem. as I can't open workbench, it appears as an unsaved project 

Sadilov posted this 21 January 2018

 Was somebody able to solve this problem?

I have Win 8.2 (64x) and GeForce GT 740 M

peteroznewman posted this 21 January 2018

Try downloading and installing the latest driver for your graphics card.

Hardikthakker posted this 08 March 2018

I too I am facing the same issue. I tried all the steps mentioned here but nothing solved the problem. Looking for a solution. Thanks

Imran7 posted this 04 May 2018

Hi everyone, It seems the issue is yet to resolve as I did not see any proper solution to how to fix this geometry editor error. I am using Ansys Student 19.0 version and having the same error. After going through the comments, I did check "SCDM" configuration through "regedit" and installation directory and have updated the graphics card driver "NVIDIA GEFORCE"; BUT the error is still there... Can someone share the success story to remove the error.


peteroznewman posted this 04 May 2018

Try this.

Jacuku posted this 22 May 2018

Getting these errors in Ansys 18.2

Geometry editor was closed abnormally

One or more parts were found to be unmodified so smart updated.


peteroznewman posted this 22 May 2018

Did you work through the Try this list above?

Hardikthakker posted this 22 May 2018

I did work through the suggestion. But this did not solve the problem. Additionally, based on that thread I would like to add that space claim opens fine. But when I try to open the 'new Geometry Design Modeler' I get the above stated error. 

Thanks and regards,


Jacuku posted this 24 May 2018

Did you work through the Try this list above?

Tried but still getiing the same error. I am using windows 10 64bit.

quietstrive posted this 27 May 2018

I have the same problem in window 7 64bit.

vganore posted this 28 May 2018

Run regedit.exe as administrator.

Do you see the folder "HKEY_CLASSES_ROOT\SpaceClaim.AnsysSCDM.182" under registry editor?

Vishal Ganore,

Hardikthakker posted this 28 May 2018

Yes I can see the folder under regedit.exe 

P.S: I am using ansys 19.1 so I see HKEY_CLASSES_ROOT\SpaceClaim.AnsysSCDM.191

Jacuku posted this 29 May 2018

It's been a week and still the geometry editor getting closed abnormally and I am unable to use the ansys for my work.


Tried everything that is posted here and still the issue has not been resolved.

vganore posted this 29 May 2018

 I have a couple of suggestions here for everybody.

1. Check whether you have right ANSYS supported graphics card. See here (other graphics card are generally not supported):

2. If you have two graphics cards (integrated + professional) then make sure that you are setting supported graphics card as primary.

3. Rename %APPDATA%\Ansys\vXXX directory to .old , reboot and try again.

4. Run productconfig.exe and install all prerequisites needed (if any).

Vishal Ganore,

ewan_matheson posted this 15 June 2018

 Tried all of your suggestions and nothing has worked. Any other options?

peteroznewman posted this 15 June 2018

I assume your computer does not have a graphics adapter on the tested list.

Your best option is to purchase an adapter from this list. That doesn't guarantee your computer doesn't have some other issue preventing the software from running. If you were also to format the hard disk and reinstall a fresh copy of Windows, then ANSYS, that is what the testing has validated will work.

Another option is to rent time on a cloud computer, but that is probably more expensive in the long run that buying a new computer.

  • Liked by
  • vganore
jose.parambil posted this 17 June 2018

I too have the same issue with Ansys 19.0. (Windows 10, 64 bit).

I am able to open SpaceClaim independent of Workbench. But, when opened from Workbench, I get the message that "The geometry editor was closed abnormally". Further, the workbench does not save any work from SpaceClaim. I am able to save geometry files directly from SpaceClaim.

My registry does have the HKEY_CLASSES_ROOT\SpaceClaim.AnsysSCDM.190 file and the folder path is correct. I do not have any external graphics card installed.

Tried the solutions listed here, but nothing worked. Kindly help in this. Thank you.

peteroznewman posted this 17 June 2018

As a work around, try the following:

1) Open SpaceClaim from the Windows Start menu, create some geometry and save that file.

2) Open Workbench and drag a Static Structural or something with a Geometry cell followed by Model or Mesh.

3) Right click on Geometry and Import the file saved in step 1.

4) Refresh Workbench

5) Open the Model or Mesh cell.

Does that get the geometry into Mechanical or Mesh?

  • Liked by
  • Swstander
  • vidhan28
DeathFly posted this 22 August 2018

Hello! I've got the same problem and none of the solutions listed above helped. I've tried steps you asked to check and found that after refreshing Workbench the error  "Geometry editor was closed abnormally" pops up again. Also I'm not sure if my graphics card NVIDIA GeForse GT 710M is being supported. 

Thanks in advance.

peteroznewman posted this 23 August 2018

Hello DeathFly,

Try turning off the Windows Firewall. It worked for one student.



bitternectar posted this 18 December 2018

I tried everything above. It still doesn't seem to work. Any other ideas?

Show More Posts