Geometry editor was closed abnormally

  • Last Post 3 weeks ago
saadabbas posted this 18 October 2017

I have downloaded "Ansys 18.2 (3.9 GB) Student version" to implement the FEA but unfortunately i couldn't be able to open the geometry. Every time i open it i get the error "Geometry editor was closed abnormally"


I looked for the solution but didn't get the proper answer.


Your help will be highly appreciated.





Order By: Standard | Newest | Votes
vganore posted this 18 October 2017

Looks like windows file registry issue. Could you please open Workbench by "Run as Administrator" option and see if that helps? 

Vishal Ganore,

saadabbas posted this 19 October 2017

No, it doesn't work as well .

vganore posted this 19 October 2017

Ok. You can try this. Let me know if it works.

Step 1:

Go to product installation path: C:\Program Files\ANSYS Student\v182\commonfiles\configs\winx64\config

Run as Administrator: AnsConfigSpaceClaim.exe

Step 2: Run file “regedit.exe” from windows, go to view> say "Refresh" then search for folder "SpaceClaim.AnsysSCDM.182"

Make sure that SpaceClaim path is correctly listed based on your installation area. Restart your PC and open Workbench.



Vishal Ganore,

hamzah posted this 31 October 2017

hi i have win 7 64bit with the same problem when i run the mesh on fluent model a message appear and says, the geometry editor was closed abnormally

i have tried  all the solution above  but it didn't work please help.

Jheferson_ga posted this 01 November 2017

hello. I have the same problem too, when I start a new project of Design Assessment the second step is make a geometry to work, but at the moment of start the SpaceClaim, Ansys shows that message. then I close it and can make my figure, but when came back to the Workbench... it doesn't receive the archive. 

vganore posted this 13 November 2017

Unsupported graphics card could be the problem. Could you please check whether you have ANSYS supported graphics card (NVDIA or AMD) in your system?

In the RUN command type: dxdiag , go to display and check the graphics card. 

Also, are you using any integrated graphics card?


Vishal Ganore,

vganore posted this 15 November 2017

Please review this document for ANSYS supported graphics cards.

Vishal Ganore,

asnalb posted this 15 December 2017


I am not entirely sure what the reason of this might be, but I get the same error message after installing the software on a machine with Windows 7, whereas it works totally fine on Windows 10. 

mohamed gamal posted this 18 January 2018

I did the steps above, but still have the same problem. as I can't open workbench, it appears as an unsaved project 

Sadilov posted this 21 January 2018

 Was somebody able to solve this problem?

I have Win 8.2 (64x) and GeForce GT 740 M

peteroznewman posted this 21 January 2018

Try downloading and installing the latest driver for your graphics card.

Hardikthakker posted this 08 March 2018

I too I am facing the same issue. I tried all the steps mentioned here but nothing solved the problem. Looking for a solution. Thanks

Imran7 posted this 3 weeks ago

Hi everyone, It seems the issue is yet to resolve as I did not see any proper solution to how to fix this geometry editor error. I am using Ansys Student 19.0 version and having the same error. After going through the comments, I did check "SCDM" configuration through "regedit" and installation directory and have updated the graphics card driver "NVIDIA GEFORCE"; BUT the error is still there... Can someone share the success story to remove the error.


peteroznewman posted this 3 weeks ago

Try this.