help creating a thru-thickness edge crack model

  • 36 Views
  • Last Post 5 days ago
eknudse3 posted this 2 weeks ago

Hello -

 

I am trying to use ANSYS workbench to insert a thru-thickness edge crack.  A video of what I want to accomplish is shown here.

 

 

I've attached an image of what I have started.  I've created a 3D model of my plate.  I also created a 'thin surface.'  I think I need to move this surface to the desired location of the flaw.  Does the thin surface need to be slightly oversized?  I want the flaw length, or depth, to be 1 inch.  Does the thin surface need to protrude from the model by some extent (maybe 10% longer and wider?).

 

How do I move the thin surface to the desired location?

 

I made to change the elements in my model to the tet shape too.

 

many thanks in advance!

Attached Files

Order By: Standard | Newest | Votes
SandeepMedikonda posted this 2 weeks ago

Hi, you can move the crack location in SpaceClaim using the Move tool, you can also change the size of the flaw surface using the tools (Such as Pull) in SpaceClaim.

Once in Mechanical, you would have the option to change the Mesh Method under the fracture object you inserted as shown in the video (About 1:55)

Regards,
Sandeep
Best Practices to post on the Student Community

eknudse3 posted this 1 weeks ago

Hello -

 

I am still really stuck here.  I don't know how to create the thin plane in the proper orientation and then move it to the correct location.  Is there a simple tutorial on this matter?  I created an XY coordinate system where I would like the new 'thin' surface which is supposed to represent the crack plane.

eknudse3 posted this 1 weeks ago

Hello,

 

I have made some progress.  I created a 3D extrusion and then used the thin/surface option by removing some faces.  It appears that I have a solid body in the correct position.  I did try to insert the crack, but I now get an error (see attached image).  Any idea as to why I am getting this error message?

SandeepMedikonda posted this 1 weeks ago

Doesn't look like you've selected the correct co-ordinate System. Change it to the one you created and try.

Regards,
Sandeep
Best Practices to post on the Student Community

eknudse3 posted this 1 weeks ago

I did try to create a local coordinate system where the Y axis is perpendicular to my surface.

 

eknudse3 posted this 1 weeks ago

I did set the mesh to tetrahedra (quadratic order).  I am not sure if I have the buffer zone set correctly or if some other setting needs to be adjusted.  I can add other views if necessary to this post to provide clarity.

SandeepMedikonda posted this 1 weeks ago

Can you flip the x-direction of the local co-ordinate axis (by 180 degrees) and see? If that doesn't work, I'll create a simple model similar to this to check.

Regards,
Sandeep

eknudse3 posted this 1 weeks ago

Sandeep -

I did attempt to flip the x-axis around as you suggested...

SandeepMedikonda posted this 1 weeks ago

Its not just the co-ordinate system. Your crack front should also be included in the body. If the crack front surface is outside of the width of the solid body, the crack mesher could not detect appropriate bounds for a crack front. 

Regards,
Sandeep

SandeepMedikonda posted this 5 days ago

To close the loop here, The arbitrary crack would have to enclosed within the body for the mesher to work.

Close