Help with Inflation

  • 55 Views
  • Last Post 2 weeks ago
mahereid97 posted this 27 May 2020

Hello I am trying to create an inflation for this blade but despite using the Total thickness option, layers at the tip are thicker and the overall inflation is distorted there. I attached photos of the inflation for different sizes and as you can see the finer i make it, the bigger the differences is.

Any ideas?

Attached Files

Order By: Standard | Newest | Votes
Kremella posted this 27 May 2020

Hello,

Could you please add your screenshots to your post? As Ansys employees, we are not able to download attachments from the forum.

Have you tried other options? First layer thickness is generally the most popular one because this gives you control over the final y+ value you would obtain in your simulation.

Please let us know.

Thank you.

Karthik 

mahereid97 posted this 27 May 2020

I dont want to control y+ but to keep a uniform thickness throughout the blade. Using Total Thickness is not making it constant. I think you should see the blade geomtery and mesh to understand where the problem might be. However, I am not sure how I can add the screenshots in the post without attaching them.

Kremella posted this 28 May 2020

Can you please try using the 'Insert Image' option? 

mahereid97 posted this 28 May 2020

Oh I am really sorry, seems like this option was not available on my phone.

Anyway these are the images. As you can see when the number of layers and and number of divisions on the blade get larger, the difference is more visible. I want my mesh size to be similar to the last image (the finest one) but with layers of constant thickness.

Kremella posted this 28 May 2020

Please reduce the growth ratio to 1.05 or 1.1 and try. 

mahereid97 posted this 28 May 2020

The growth rates I am using in these images are either 1.04 or 1.05

Kremella posted this 28 May 2020

You must have already tried this. However, let me still ask you. Could you please double the number of layers (keeping the same thickness) and try?

mahereid97 posted this 28 May 2020

Same outcome but first layer becomes smaller to accomodate more layers. I can't understand why the mesher has to thicken the layers on the tip sides

Kremella posted this 28 May 2020

Are you seeing the similar global sizes (not in the inflation layers) in your reference mesh? In your case, could you also reduce the global mesh size? 

Also, in the two cases you are comparing, is the overall thickness of your inflation mesh the same?

mahereid97 posted this 28 May 2020

Does the mesh size outside the inflation affect the interior layer thickness? Anyway mesh size is constant all around the blade, and even if I make it larger or smaller it does not solve the problem.

And the images have different total thickness to show you that the difference gets worse when it increases.

Kremella posted this 29 May 2020

Hello,

As you already are aware, in the case of 'Total Thickness', the spacing between the layers is governed by three parameters - growth ratio, maximum thickness, and number of layers. One quick dirty test to verify your inputs is to change the growth ratio to 1. In this case, all your inflation layers should have a constant thickness. This will give you a good sense of what your average distance between the layers would be. If you are looking for a finer clustering, you should be increasing the number of layers and/or decreasing the maximum thickness value. Here are some tests I ran at my end.

Growth ratio = 1, Max thickness = 1 mm, Number of layers = 30:

Growth rate 1.2, Number of layers 30, total thickness 1 mm:

Because Meshing is trying to cluster near the wall, there spacing between the layers increases away from the wall.

I hope this brings some clarity to your question.

Thanks.

Karthik

mahereid97 posted this 29 May 2020

Thank you very much for your interest in helping me with this case.

Upon digging in the mesher settings, I found a parameter called Max height to base ratio in the advanced options of the global inflation control. Turns out this number is set to 1 by default which means layers stop increasing in height when their height/base reaches 1. In my case the big curvature difference forces some layers to stop growing causing the big distortion we see.

I fixed that problem by increasing the Max height to base ratio to 2.

I want to finally ask you if you if there's advanced options for biasing an edge sizing feature. As you can see in the images below, the couple cells next to tips grow quite large. I need some sort of geometric or exponential bias factor instead of the linear default one. Is something similar available?

Again thank you very much for you help.

kkanade posted this 02 June 2020

i did not go through all comments. 

just check if you can increase max size for tet mesh. if you can increase it, the jump between tet and imflation may be reduced. 

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

mahereid97 posted this 03 June 2020

The problem is not the difference between the inflation size and the tet element size outside. The first problem was that the inflation layers stopped increasing in height in certain locations causing the overall thickness to be non-uniform. I worked that out by changing the max height to base to 2 instead of 1. Now the new issue is that just next to the tips, the length (not height) of the layers are bigger than the rest. I need something to control element size. Please check my previous reply for the images.

Kremella posted this 03 June 2020

Please use an edge sizing on the curved edge. Please specify the number of divisions or edge sizes. Either one should work. This would help you capture the curvature better.

Thanks.

Karthik

kkanade posted this 2 weeks ago

Please go through sizing help and following video. 

Regards,

Keyur

 

If this helps, please mark this post as 'Is Solution' to help others.

Guidelines on the Student Community

How to access ANSYS help links

 

Close