Hexa Meshing of Ventilation Air Duct

  • 65 Views
  • Last Post 03 June 2019
ayodele1 posted this 21 May 2019

Hello everyone,

I am generating hexahedral mesh in ANSYS ICEM CFD 16.1 for flow analysis in ventilation air duct. My pre-mesh is not looking alright - mesh only cover a larger section of the geometry (see below images). I used the native 3D hexa meshing approach i.e. blocking, association, application of mesh parameters (Curve Mesh Setup) with the blocking carried out with a T-shaped topology. I also tried creating O-grid Splitting method, no improvement. Below are the images of my pre-mesh (3D, X-Z view, Y-Z and X-Y respectively). Kindly assist me with ideas on getting a proper pre-mesh for this geometry. 

Many thanks in anticipation.

Regards,

Ayodele

Image from native 3D meshing

 

Order By: Standard | Newest | Votes
raul.raghav posted this 21 May 2019

Looks like there might have gone wrong with the association. Could you post a picture of the Blocks from the Mesh?

Rahul

ayodele1 posted this 21 May 2019

Thanks Rahul.

The following are the 3D and X-Z views of the Blocks from the mesh. I look forward to your thoughts ...

Thanks a ton

Ayodele

raul.raghav posted this 22 May 2019

Ayodele, can check the minimum value for the Determinant from the Pre-Mesh Quality. If its negative, you might have an inverted block (which might be the case).

Rahul

ayodele1 posted this 22 May 2019

Dear Rahul,

Thanks for your response and suggestion. I just checked the Pre-mesh Quality Histogram and found the minimum to be "0", a total of 1,992 elements at the section having the inappropriate meshing have determinant values of <0.4. What could I be doing wrong?

Kind Regards,

Ayodele

 

raul.raghav posted this 23 May 2019

If you notice carefully, the minimum determinant is shown as -1 on the graph (just not visible as the X-axis value is set from 0 to 1). To see the negative elements, set MinX value to -1 to a MaxX Value to 1 in the Histogram Options. Refer to attached image for reference:

To fix the problem, you need to fix the inverted blocks. See the following screenshot for reference:

Rahul

ayodele1 posted this 25 May 2019

Hi Rahul,

You are indeed correct, I found the minimum determinant to be -1, thanks. I however tried to Fix Inverted Blocks, but no change observed, the determinant remains -1 and the section without mesh remains the same. Is there anymore step I could take to address this?

I am grateful for your time and assistance - thank you.

Ayo  

rwoolhou posted this 03 June 2019

I've not used ICEM CFD in about 20 years so am slightly rusty: we used to add all of the blocking manually back then. Can you delete that block & recreate it? 

Alternatively, ANSYS Meshing or Fluent Meshing with the Clean CAD Workflow (2019R1) will give you a mesh with much less manual intervention. 

Close