Hooking define_turb_schmidt UDF

  • 45 Views
  • Last Post 19 November 2018
  • Topic Is Solved
LukeM posted this 16 November 2018

I am using a DEFINE_TURB_SCHMIDT macro in my simulation. I wrote the code and successfully compiled it in Fluent, but I am unable to hook it to my simulation. I attempted to follow the instructions in the user's guide ("Hooking DEFINE_TURB_SCHMIDT UDFs"), including a careful selection of turbulence models and selecting the Species Transport model, but I was unsuccessful. In particular, the Viscous Model Dialog Box in my simulation did not have the Prandtl and Schmidt Numbers User-Defined Functions box. See below. 

 

image.png   This dialog box differed from the sample dialog box in the user manual.    Is there a reason why my dialog box is different? Do I need to select another model?    I attached a few more screenshots of my simulation.

Attached Files

Order By: Standard | Newest | Votes
abenhadj posted this 16 November 2018

Only single phase.

Best regards,

Amine

seeta gunti posted this 19 November 2018

I guess your are using multiphase multispecies model. You won't see the option for turbulent schmidt number for multiphase models. In our customization model, it is clearly mentioned. 

 

For single phase, you can see the option as below

Regards,

Seeta

kkanade posted this 19 November 2018

As its for single phase only, can you please mark this as 'Is Solution' to help others on forum. 

Close