How to make the conformal quad mesh throughout the whole geometry

  • 85 Views
  • Last Post 13 December 2018
  • Topic Is Solved
xiaofuli posted this 06 December 2018

   I import a 3D geometry file from solidworks into ANSYS Workbench 18.1, I tried to make a conformal quad mesh within the whole structure, but it does not work, I use the split body function in the Spaceclaim to make the model into 3 different parts and use the mesh method with hex dominant. I even increase the number of the elements, it does not work very well, defeaturing mesh and triangle elements still occur. Could someone give me some help?

 

Thanks

Li 

Attached Files

Order By: Standard | Newest | Votes
SandeepMedikonda posted this 06 December 2018

Hi Li,

If the body is sweepable you can try using the sweep method. If not or doesn't work by default, you can also try face meshing or manually specifying the source and target faces to generate a successful sweepable body. See here.

Regards,
Sandeep
Guidelines on the Student Community

  • Liked by
  • xiaofuli
xiaofuli posted this 06 December 2018

Thanks for the help

                  I tried with sweep method, but the error will happen in this case and the face meshing does not work as well. Additionally, I could not log in to open the link you sent it to me. I hope that you could give me some detailed information about my question.

 

Best Regards

Li

SandeepMedikonda posted this 06 December 2018

If you don't know how to use online help, please see here.

Regards,
Sandeep

xiaofuli posted this 06 December 2018

Thanks for the reply, after I follow the instructions, The link still could not be opened.

Best Regards

Li

SandeepMedikonda posted this 07 December 2018

Li, meshing often receives a lot of improvements in a version change. So, I recommend you to upgrade the latest version (19.2). Which you can easily download from the first figure at the top of this page.

Also, help has moved online only in v19 or later, looks like you have the older help viewer. In this, case you might want to search for Mesh Sweeping in the Meshing Users Guide.

Regards,
Sandeep

peteroznewman posted this 08 December 2018

Hello Li,

I'm travelling and this laptop only has 18.2 so I can't give you back an 18.1 archive, but I will make screen shots to explain.

1) The geometry has overlapping solids causing interference. Fix that in SpaceClaim by using the flat face of the long part to Split Body on the end part to delete the triangular piece. I will assume you did that.  Next, in SpaceClaim, set Share Topology to Share.

Sandeep thinks as I do, that Sweep is a good Method in this case. In Mechanical, RMB on Mesh and Show Sweepable Bodies.  The long part will not turn green. The reason is the faces don't match on the top and bottom.  At most of the junctions, there is a line across the top and bottom face at the transition. At one of the junctions, there is no line. There either has to be all lines or no lines in order to sweep.  Do you see the missing line?

Unless you need to divide the face to apply a load, it is best to remove all unnecessary lines.  This is easily done in SpaceClaim by picking the Repair tab and then clicking the Extra Edges button. It will remove all the lines on the top and bottom face.  Refresh the Project then in Mechanical, RMB on Mesh and Show Sweepable Bodies and the long part turns green.

 

2) You mentioned you are losing features due to mesh defeaturing, so turn it off.

3) Delete all the Hex Dominant mesh controls and add a Mesh Control Method called Sweep.

I see now why you had those lines!

To Sandeep's point about improvements to meshing in each version, here is what the 19.2 mesh looked like with the edges removed.

When I added the missing line, the body didn't show as Sweepable. Instead, I Split Body at each transition. Now with Sweep Method applied to just the center body, all the other bodies follow along because of the Shared Topology.

Kind regards,
Peter

  • Liked by
  • xiaofuli
xiaofuli posted this 08 December 2018

Thanks very much for your helpful reply.

1. I followed your instructions, delete the overlapped parts and also make the whole body sweepable, but there is one issue that I could not solve, There is no option that I could choose share for share topology. As it shown below.

 

2. After I follow all the steps, the shorter part (in green color) has distorted quad element mesh, as for this issue, how could I make the whole body has a very uniform quad mesh, the workbench file is attached, if you open up the transient structural analysis with the name "mesh_improvement", you will see this mesh problem.

 

Thanks for the help

Li

Attached Files

peteroznewman posted this 09 December 2018

Hi Li,

1. You have to pick the system at the top of the tree in the outline then in the window below you can find Share Topology.

2. I assume the most important elements are around the hole. When you sweep a single body, select a Source face in the sweep, then RMB on the sweep and Inflate this Method. You then get an inflation mesh control with the face already selected. Use the Edge filter to select the edge of the hole.  Also add a sizing control to this edge and specify 18 divisions.

  • Liked by
  • xiaofuli
xiaofuli posted this 09 December 2018

Thanks very much for the helpful reply

1. I am using the 18.1 of Workbench, but there is no share option within share topology, I do pick the whole geometry, as you could see the SYS2 in orange color shown below, is it the reason that I do not have it in my ANSYS package? I tried with the merge option. but it does not work for the conformal mesh.

2. I follow your instructions concerning "select a Source face in the sweep, then RMB on the sweep and Inflate this Method. You then get an inflation mesh control with the face already selected. Use the Edge filter to select the edge of the hole.  Also add a sizing control to this edge and specify 18 divisions", but the issue is that I waited around 1 hour, the mesh still does not finish, could you please open up the transient structural analysis with the name "mesh_improvement" to check whether there is some thing wrong with my manipulation?

Thanks very much

Best Regards

Li

 

 

Attached Files

peteroznewman posted this 10 December 2018

Hi Li,

1. I only have 18.2 with me today.  In 18.1 try to use the Workbench tab and click on the Share button.

2. A few things were wrong with your attempt.

a. The Mesh settings had sizes that were too large for the geometry. Here is what worked.

b. You defined a Sweep with a Source Face, which was good...

...but you picked the opposite side of the part to define Inflation, it should be the same side as the Source face.

You need these settings for Inflation.

You also picked the opposite side for the edge sizing, it should be the same side as the Source face.

With those settings you get this mesh on one end...

...and you get this mesh on the other.

Here are the Mesh Metrics for Skewness.

Regards,
Peter

  • Liked by
  • xiaofuli
xiaofuli posted this 13 December 2018

Thanks for the helpful reply

             The mesh generation part works very well as I followed your instructions, but the share option button is in grey color and I could not pick it manually, is it the reason that I might not have it in my ANSYS package, in this case, will it influence the mesh quality for conformal mesh?

 

Best Regards

Li

SandeepMedikonda posted this 13 December 2018

Click on SharePrep.

Close