How to run simulations without taking too much computer space

  • 201 Views
  • Last Post 28 January 2019
designteam2 posted this 13 January 2019

I am having a problem where if I run a simulation, the files take up all of the space on my hard drive, which should not be happening as it's an almost empty desktop computer. Running a simulation overnight produced 4000 files. What are the settings to produce less files while still being able analyze the data? 

Order By: Standard | Newest | Votes
SandeepMedikonda posted this 13 January 2019

What software are you using?

If it is mechanical, You can control what is being written to an extent by going to Analysis Settings > Output Controls and choose the interested output quantity and time to be stored. Please see the help.

Please see these articles:

Article 1

Article 2

Regards,
Sandeep
Guidelines on the Student Community

designteam2 posted this 14 January 2019

I am using the fluent software to perform my simulations.

rwoolhou posted this 15 January 2019

Have you got Autosave switched on? If so decrease the frequency of the save, ie save every 5 time steps rather than every 1. 

designteam2 posted this 16 January 2019

Yea, I changed my autosave setting so that it saved every 500-time steps, however, I still have large amounts of data in my fluent folder.

rwoolhou posted this 17 January 2019

Is that because you have many files or that the files are fairly big?  In some of the models I deal with 3-5GB isn't uncommon for a data file, so you can imagine how big (and how quickly we can fill) the hard drives needs to be. 

designteam2 posted this 25 January 2019

I have several cdat files that are tens of thousands of kilobytes large as well as cas files that are thousands of kilobytes large. The program saves about 4 files every minute, but since I am running a simulation for hours, that's thousands of files for one simulation, taking up way too much space.

rwoolhou posted this 25 January 2019

Yes, that sounds about right. This is why we try and run steady state calculations: less data to process. It's also why we may use simpler models or coarser meshes at times to reduce the storage needs: bear in mind we may be looking at 4-500 million cells in some models and clients run larger grids than that. 

The options you have are to reduce the save interval so you have less files or use a bigger disc. This assumes you're saving with a label ending in .gz as this will autozip the files. Fluent knows what this is, so you'll have   myfile.cas.gz  which will reduce the disc usage too. 

 

designteam2 posted this 27 January 2019

What is the proper way to reduce the save interval to save less files to maybe 1 file every half hour? Where can we change the save interval?

rwoolhou posted this 28 January 2019

In autosave just change the frequency so the save happens less often: as I don't know how quickly the model runs I can't give a value for this. 

Close