Long loading times and unable to run with 4 cores in ANSYS AIM

  • 108 Views
  • Last Post 08 October 2018
vestdam posted this 04 October 2018

Hi there

After having trouble meshing my geometry the way I wanted in Ansys AIM 19.2, I switched to the 19.0 version, which works fine during meshing.

The first problem I encounter, is that when I change the number of processes to 4 instead of the default 2, the solving process will not run. The program gets stuck after initializing the solution.. This was not a problem in the 19.2 version.

I am able to run the simulation using only 2 processes, however, I assume this is slower.

The next problem is encountered when I save and load a project with the results included. Opening a 300Mb project in Ansys AIM 19.0 and 19.2 takes between 8 and 15 minutes. How can this be?

I hope you have some answers, as I am facing a long period of using Ansys AIM.

Attached Files

Order By: Standard | Newest | Votes
abenhadj posted this 04 October 2018

Are you working with Student Version?

Best regards,

Amine

vestdam posted this 04 October 2018

Hi Amine

No, it is not a student version.

/Kasper

SandeepMedikonda posted this 04 October 2018

Hi Kasper,

  Can you please provide your computer configuration (RAM, Graphics Card Info etc.)? It has to be first noted that you are using the beta features. 

  Having said that, how big is the problem you are dealing with? i.e., what are the mesh statistics and non-linearities involved? As you might already know, the scalability depends on your model.

Regards,
Sandeep
Best Practices to post on the Student Community

Gary_S posted this 04 October 2018

Hi Kasper

 Lets work strictly with version 19.2 and work out the meshing and slow load times.

 Beginning in AIM 19.2, we use the curvature size function for Mechanical meshing defaults.

 In earlier releases, we used the adaptive size function as default. If the meshing was satisfactory in 19.0, we should be able to uncheck "Use Predefined Settings" and set same default values in 19.2 as was in 19.0 for Growth Ratio, Minimum Size, Curvature Normal Angle, and Defeaturing Tolerance. 

 

Regards,
Gary

 

  • Liked by
  • SandeepMedikonda
  • pgl
vestdam posted this 05 October 2018

Hi guys,

Thanks for your responds.

Regarding the computer, it is a 32Gb ram, Intel Xeon E5-1630 3.7Ghz and Nvidia Quadro P2000 GPU.

The geometry is a plate with a pipe welded to it. The plate is only 1 mm thick and 500mm long. I think one of the things that are making it slow, is that I have manually drawn all the welds, as I have to simulate the heat flow in the welds. There are 499 welds. Water is flowing in the pipe, so I am simulating heat transfer and fluid flow.

Regarding the meshing in 19.2. I previously tried exactly what you mention Gary, and I even use curvature in 19.0, however, doing exactly the same settings as I do in 19.0, the program is simply not able to build the mesh in version 19.2. It is having trouble meshing the pipe connecting the fluid zone and all the welds. Could it be something changed in Spaceclaim from 19.0 to 19.2? I would like the mesh to be non-conformal, but it seems that is not really an option in 19.2.

Another thing bugging me in 19.2 is that the process bar when meshing does not show the progress. It just jumps to 100% initializing meshing and then stops. In 19.0 it shows "meshing part 435/500" and I can follow the progress.

I will try once again to build the mesh in 19.2 now that it has been a while since I last used that version.

/Kasper

vestdam posted this 08 October 2018

Update:

Apparently Ansys AIM 19.0 does not consider imprinted faces when meshing, and 19.2 does. By removing the imprinted faces, I was able to make a non-conformal mesh in 19.2, but then I have to live with that the non-overlapping faces are assigned as insulated walls (please confirm this is the case).



Also, 19.2 seems much slower than the 19.0 version, but as long as it solves my problem, I'm fine.


/Kasper

Close