Mesh Interface Errors

  • 109 Views
  • Last Post 17 September 2018
jesseahlquist posted this 13 September 2018

Hello,

I am attempting to model the airflow through a cold trap see in the picture below:

 

 

Air is supposed to enter the top nozzle, travel down the tube into the reservoir region, then proceed back up the assembly to the outlet.

I initially, had these separated as two separate parts, where the cutout region was created by a Boolean subtract. However, when transferring the mesh to FLUENT an error occurred in which the contacting surfaces of the meshes had issues. I saw there was a section in FLUENT that allows you to make a relationship between these two regions, but I don't know the correct one to use. They are simply stationary walls, that should restrict the flow path to the one described above. 

I had both parts described as fluids because I ran into an earlier error where there were illegal fluid-solid zone interactions. Would listing them as both solids, but using named selections to create a fluid volume instead?

The second approach I tried was to combine the parts into one, to ensure a conformal mesh along that interface. This worked great until the solution showed what was really going on: (see Picture)

 

The air is just escaping directly to the outlet! Is there a way I can define within FLUENT the solid walls is cannot cross?

If there are any suggestions for how to approach this problem, they would be most welcome. Many thanks!

Jesse

Order By: Standard | Newest | Votes
rwoolhou posted this 14 September 2018

The initial cause is you haven't shared the topology. In DesignModeler create a multibody part: in SpaceClaim use ShareTopology. This means you can then label the surface as a wall in Meshing which tends to stop the flow.  You can remesh with a much smaller cell size then too: you're aiming at 6-10 cells across any gap as a first pass at a mesh. 

Assuming you're using R19 click on Help in the Interface panel and it'll explain all of the options. 

jesseahlquist posted this 14 September 2018

I noticed no significant difference after turning on share topology option within DesignModeler. I think this may because I already created the bodies using a boolean relation, thus the contacts were already created.

For decreasing cell size is that best accomplished through inflation or sizing options within meshing? 

Additional Question (SOLVED): I have a symmetry plane defined in the name selections, but this is not being passed naturally to FLUENT. Suggestions? -- Enable option that symmetry plane should be passed to the solver

rwoolhou posted this 17 September 2018

The Boolean means you have the split shapes, but unless you have created a multibody part (or used share topo) you won't get a conformal mesh. These generally make it easier to work with the model: they have their uses but I'd suggest avoiding for now. If you look in the image you posted you can see the mesh isn't connected. 

I'd decrease the cell size using the mesh controls, reduce the maximum surface and volume cell size: size functions will help. Inflation is used to get a highly resolved near wall mesh for wall effects (read the wall functions section of the turbulence documentation) but in this case probably won't make much difference to the solution. I suspect once you've got a result you'll need to remesh as you may not sufficiently resolve the flow on the first attempt: again look up mesh independence. 

Close