Missing faces on solid bodies

  • 2.1K Views
  • Last Post 17 July 2019
kaiyeungli posted this 14 March 2019

Hi there,

I have created a solid model which works fine (fully defined and solved), however, the orientation of the assembly (i.e. global csys) is actually upside-down to what it would be in real-life (global Y-axis is pointing downwards, not upwards). 

As a result, I used the move-function in SpaceClaim to rotate the entire CAD model 180 degrees. The problem is that, after I rotated the model, some of the faces of the solid model in Workbench appear to be missing. 

The image below shows an example of this. This is one of the many bodies in my model. The bottom face appears to be missing - I think that it's because the the surface normal is pointing into the bodies instead of out of the body.

In addition, the rotated bodies with missing surfaces appear to be 'hollow'. This is very obvious when I create a cross-section. 

This does not appear to be a problem in SpaceClaim. In SpaceClaim, there are no surfaces missing, all surface-normals are correct and the bodies appear to be solid (as they should be). This problem also does not appear when I just translate the model. 

Would anyone be able to help me with this? I attached an archive file of both the original and rotated/faulty model for reference.

 

Kind regards,

Kai-Yeung

Attached Files

Order By: Standard | Newest | Votes
kkanade posted this 14 March 2019

as ansys employees we can not download attachments. others can pitch in. 

please check the axis of rotation. please select correct axis of rotation. 

if you are not chaning relative positions of the bodies, then there should be any change in connectivity. 

  • Liked by
  • kaiyeungli
kaiyeungli posted this 14 March 2019

I select every component and all the bodies within them when I perform the rotation, so they should all be rotating in the same way no matter what axis (X or Z) I choose, right? I am not directly rotating the any of the faces themselves. Most of the faces are actually correct. 

I am not changing the relative positions of the bodies because I rotate the entire component. Edge/face connectivity is the same (I checked by displaying Edge Coloring: By connection).

It is worth noting that if I turn off Share Topology in SpaceClaim, that the problem goes away, but comes back when I turn Share Topology back on. It also goes away when I merge all the bodies within a component, but comes back when I split it again. I do the splicing to help with meshing.

peteroznewman posted this 14 March 2019

I would use the original geometry with "up" in the negative Y direction and not rotate the body. If you have to add Standard Earth Gravity load in Mechanical (or Fluent), you can set that to be in the negative Y direction. I sometimes get geometry where Z is "up" and this is what I do.

  • Liked by
  • kaiyeungli
jpnrodrigues posted this 17 July 2019

I'm leaving this here hoping an explanation/solution is provided. My case is mostly the same as the one presented above, I have some sort of a pin that I've sliced to get a nice mesh and the original one works perfectly but when I copy it and move it/rotate it to another location it "loses" the inner faces and refuses to sweep mesh.

Original one, no issuesCopied and moved, problematic 1Nice  mesh on original

 

peteroznewman posted this 17 July 2019

jpn, I cannot reproduce this defect in ANSYS 2019 R2.

What version are you using?  Please attach an archive to your post.

Close