Numerical Problem Size limits with a model that should run

  • 7.2K Views
  • Last Post 08 April 2018
  • Topic Is Solved
jonnyflowers posted this 09 October 2017

I am attempting to run a simulation that has 6636 nodes, It will not run no matter what I do because it has the error "The version size limits( NODES )have been exceeded."

Can someone please help me out with this?

Thanks

  • Liked by
  • Sergey
Order By: Standard | Newest | Votes
vganore posted this 09 October 2017

If you are using our ANSYS student product or teaching product then it has a nodes/elements limit of 32k for structural. Could you please post screenshot of your error + statistics area which shows nodes and elements?

Vishal Ganore, ansys.com/student

jonnyflowers posted this 09 October 2017

Hi,

Screenshots attached below

 

vganore posted this 09 October 2017

Looks like you have meshing elements/nodes under control. What about geometry? How many bodies have you generated? How many systems are you using under workbench?

Vishal Ganore, ansys.com/student

Sergey posted this 17 October 2017

I have few requests from students facing the similar "numerical limit" issue. The most simple way to reproduce the problem is to exceed the specified limit (32k) at least once, and in the following runs the numerical limit error will pop up with no respect to the actual size of the model. Duplicating the project or clearing generated data or closing the workbench or restarting the pc do not solve the problem. However, if you duplicate the Model cell and make a new Setup cell, it works fine. So the issue seems to be seat somewhere in the Setup cell of the project. Still have no idea how to avoid the error without redefining loads and supports. I also have requests regarding the error about geometry size limits in DM. However, I found no info regarding the limits existing for student version of DM.

vganore posted this 17 October 2017

Strange. Let me find out. About Design modeler (DM) geometrical limit, it can handle-

Maximum number of bodies=50,

maximum number of faces=300

Vishal Ganore, ansys.com/student

  • Liked by
  • Sergey
Dbendix posted this 18 October 2017

i am having the same problem

 

jonnyflowers posted this 19 October 2017

The issue definitely has nothing to do with anything exceeding limits at the moment, I may have exceeded this during an initial run, so what Sergey said seems likely, it could be as simple as a variable not being reset in the setup cell.

Finch8 posted this 27 November 2017

Hi! Have someone find a solution for this problem? 

vganore posted this 27 November 2017

Which version are you using? I am using 18,2 and it is working fine even after I exceeded the limit and readjusted mesh to bring the node count within limit. 

Vishal Ganore, ansys.com/student

Naji posted this 29 November 2017

I already have meshed in Design modeler (DM), and everything is well, I have no problems in my mesh with ansys 18, I have about (10M) elements in my project.. you can try with Design modeler (DM)

Naji posted this 29 November 2017

jonnyflowers posted this 13 December 2017

I still seem to be having this issue,  It is driving me absolutely nuts!

My mesh is currently on 2600 elements and I cant solve it.  This is a nightmare.  I literally have to start everything again everytime this happens!

Mr Berg posted this 15 December 2017

i have this exact problem in ANSYS Student 18.2, i have to rebuild the simulation when i exceed the limits to get the simulation to run. I have tried to use symmetry to minimize the problem but with fillets (that are taking up much of the stress in the material) the licence limits are often exceeded. This is a problem that persists when i try to create a second system and sharing the information from engineering data and up to model.

peteroznewman posted this 15 December 2017

Mr Berg,

It sounds like your Student license is working as it should. When the count of nodes+elements > 32,000 the solver will not run, and when the count is < 32,000 the solver will run.

Jonnyflowers is on ANSYS Student 17.2, which has a defect where once a model exceeds a count of 32,000 and the solver refused to run, simply changing the mesh to a lower density to get the count below 32,000 does not allow the solver to run. The model is "stuck" in the "over-the-limit" state, and the model has to be rebuilt before it will solve again.

For version 18.2, if you exceed the limit, you can simply change the mesh density to get below the limit and the solver will run. It doesn't get stuck.

jonnyflowers posted this 15 December 2017

I am using 18.2 and I am still having this issue.

peteroznewman posted this 15 December 2017

Vishal could not reproduce the issue on his Student 18.2.  
I will try my Student 18.2 tonight and update this post with my results.

jonnyflowers posted this 15 December 2017

I can provide my files if you would like

To reduce it to under the student limit, just change the mesh sizing control from fine to coarse

Attached Files

peteroznewman posted this 16 December 2017

I tested ANSYS Student 18.2 using both the Iterative and Direct Solvers with a mesh that was first over and then under the Student node+element limit. In both cases, I got the refusal to solve, then reduced the mesh density and had a successful solve without changing anything but the default element size. I could not reproduce the problem jonnyflowers experienced.

jonnyflowers posted this 16 December 2017

Hi, Sorry didnt have access to my workstation last night.  I have just uploaded the files

peteroznewman posted this 17 December 2017

Hi Jonny, I feel your pain; I was able to reproduce this defect on your file, but...

       I found a way to reset the defect!

In Mechanical, right click on Geometry and select Update from Source. After the update completes, the solver will run if the mesh is below the limit.

Hopefully, this thread will help everyone with this defect.

I have some suggestions about your model that I will put in a new thread with a new title.

  • Liked by
  • jonnyflowers
  • raul.raghav
jonnyflowers posted this 17 December 2017

Thank you. I will have a go tomorrow.

Where is the new thread?

peteroznewman posted this 17 December 2017

I have put the suggestions in this new thread.

Fabricio.Urquhart posted this 07 April 2018

I have the same problem and the number of nodes and elements is not over 32k. Can anybody help me?

 

Thank you!

 

The model is attached.

Attached Files

Fabricio.Urquhart posted this 08 April 2018

Peter, firs of all thank you very much!

 

Then I have some doubts:

When you said: "You should always have a minimum of two solid elements through the thickness of any part", I did not understand what you mean to say?

And another doubt that I always have, is how to derminate the number of substeps.

 

Thank you

peteroznewman posted this 08 April 2018

Dear Fabricio,

With only one solid element through the thickness of a thin solid body that is subject to compression or bending, there is an invalid solution that is called the "hourglass" mode. You don't want that to happen. That is why we use shell elements, they have extra degrees of freedom at each node: rotations, and equations to model bending behavior that solid elements don't have. If you put several solid elements through the thickness, you can reduce the likelihood of having an hourglass mode and the extra elements can more accurately represent the bending than a single layer of solid elements. I refer you to this page for more info. That page is in reference to the warning message you will sometimes see from the solver that it detected only 1 solid element in two directions.

There are two exceptions I know of regarding the guidance for putting at least two solid elements through the thickness of a solid body.

1) When you have a thin solid and mesh it with solsh190 elements. They have extra degrees of freedom to model the bending behavior accurately with a single layer of solid elements. Read this post for an example of the mesh control needed in Mechanical to deploy those elements.

2) When you assign a solid body the property of Gasket and assign a Gasket material, then the mesher knows to put only one element through the thickness of a thin planar solid body.

SUBSTEPS
Initial Substeps
Make this number large enough so the substep converges in less than 26 iterations and ideally less than 6 or 7 iterations.
Minimum Substeps
Make this number 1 if the solution converges to the end of the step without issues. Sometimes, the solver gets into trouble not at the start of the step, but near the end of the step. For example when using a material model with plasticity, there is no plastic strain at the beginning of the step, but there is near the end of the step, and if the solver takes too large an increment, it gets into trouble with distorted elements. Setting a high number for Minimum substeps forces the solver to take small sized load increments and makes it more likely to find convergence in less than 26 iterations. Another reason to use a high number is if you are plotting out a graph and want plenty of points on the curve.

Close