NVIDIA Library Requested but not Enabled for GPU acceleration in Ansys Workbench static structural

  • 423 Views
  • Last Post 13 November 2019
learner posted this 01 October 2019

Hello all

I tested gpu acceleration, but it does not work. situtation is below.

*** FATAL ***

An error has occurred when trying to check for any GPU devices on machine .... Error code = 35 which translates to: CUDA driver version is insufficient for CUDA runtime version.

Please check your GPU device driver level and verify that a supported GPU device has been installed correctly.

GPU Acceleration: NVIDIA Library Requested but not Enabled

GPU Device with ID = 0 is:

GPU Driver Version: 9.10

************

Environment is below.

OS Platform: windows 10 64 bit

Video Adapter: 

1. Intel(R) UHD Graphics 630 (i disabled this device)

2. NVIDIA Tesla C2050

cuda runtime version and driver version are the same 9.1 by deviceQuery.

cuda: 9.1.85_win 10, nvidia driver: 390.85-tesla-desktop-win10-64bit-international

ANSYS product 2019R3 workbench

I set ANS_OVERRIDE=1, and cuda driver set to TCC mode.

but error has not gone, please let me overcome this error. thanks.

 

 

Order By: Standard | Newest | Votes
tsiriaks posted this 02 October 2019

Open CMD Prompt, then issue the following command

"C:\Program Files\NVIDIA Corporation\NVSMI\nvidia-smi.exe"

then, post the screenshot of the output here.

Thanks,

Win

learner posted this 02 October 2019

Thanks for your reply.

output is below.

tsiriaks posted this 02 October 2019

Thanks for the info.

Can you try this driver ?

https://www.nvidia.com/Download/driverResults.aspx/143683/en-us

learner posted this 03 October 2019

I already tried that driver, but it couldn't install that driver.

As you know NVIDIA drivers are often fragile with like below error message.

so I tried other drivers which are able to install and cuda toolkits, but they also didn't work.

Please help me, thanks

tsiriaks posted this 03 October 2019

That's very odd. Can you launch dxdiag and post screenshots of the first tab and the 'display' tab ?

learner posted this 03 October 2019

Yes.

tsiriaks posted this 07 October 2019

How did you disable the Intel graphics ? It's still using Intel by default. 

I'd recommend to try disabling Intel in the BIOS level, then try dxdiag again. It should show Nvidia this time. Then, try using ANSYS. (No need to try install the Nvidia driver at this time)

Thanks,

Win

Beb99 posted this 13 November 2019

I'm also trying to enable CUDA. Here's a screenshot.

Close