Parameter error

  • 169 Views
  • Last Post 05 December 2018
mmd95 posted this 01 December 2018

Dear community, this is my first post. 

I have encountered problems at the time of setting up the OUTPUT PARAMETERS of a static structural analysis. Im intending to optimize the groove shave of a brake disc and i set up 3 groove parameters in SpaceClaim. When in Workbench (Mechanical), as soon as i set the "Equivalent Von Mises Stress" as parameter, a message pops out stating "An unexpected error occurred: No system is associated with the component Setup 1".

I still have no clue of what can be the cause of such  mistake since when i open a new file it is totally possible to define a parametric model that works properly.

 

Image: Geometry parameters

 

Image: Parameter Setup

Image: My current workflow

Image: Mechanical Workbench interface

Image: One of the desired output parameters

Image: Error

Image: updated, appears as parameter but it doesnt work

 

I would be very thanked if anyone could solve this or give me insight of how to do it. Thank you very much for your time!

 

Miguel Moreno

 

Order By: Standard | Newest | Votes
peteroznewman posted this 01 December 2018

I made a video to show a very simple example of making Parameters with SpaceClaim and Workbench. See if there is anything that you missed.

Regards,

mmd95 posted this 02 December 2018

Thank you for the fast response. It is possible for me to operate with parameters properly in other Project Files. Nevertheless, in my specific project, i am unable to set the output parameters up without receiving an error message in my desired SpaceClaim geometry.

I am gonna try a different geometry in this very file for testing wether its a problem of the geometry itself or from the project settings. Thank you for your time Peter.

Regards, 

Miguel Moreno

peteroznewman posted this 02 December 2018

Miguel,

Verify that each parameter can move the geometry over the full range of the parameter values, including combinations of two or more parameters going to their extremes.

If you are still having issues, please reply with a Workbench Project Archive .wbpz file attached after you post a reply, and I will take a look using ANSYS 19.0

Regards,
Peter

mmd95 posted this 04 December 2018

Hi,

Sorry for the late response, i have already tried every possibility (even in new files) and i still receive the same error message. Therefore i attach you the project file below, if you had the time.

The target of the current optimization process is to find the optimal groove shape given 4 parameters (3 Radius, 1 Length).

Thank you for your time Peter, best regards

 

Miguel Moreno

mmd95 posted this 05 December 2018

 I am unable to attach any link right now, the website doesnt allow me to (Error 404). I will try it some time later

Close