Particle Tracking

  • 63 Views
  • Last Post 24 June 2019
liliana_augusto posted this 12 February 2019

Hello!

 

I have a 2D axisimetric swirl simulation of a flow inside a labyrinth. The simulation is a transient case.

I inject just one particle insde the domain (DPM), and the tracking is also transient. I got the visualization of the path of the particle inside the domain for a given period of time. Although, I would like to generate a picture (not an animation) of the path of the particle.

Using the option "particle tracks" I only got the position of the time at a given time step. Is there any way to "compile" all these information regarding the position of the particle for a set of time steps?

 

Thanks!

Order By: Standard | Newest | Votes
Tareq posted this 13 June 2019

Dears,

 

Please once i am doing the animation for particle track as the figure below i receive the below error and the animation does not save any movement for particles while the contour animation is working perfectly, please any suggestions for this problem?

(ani-monitor-update 4 #t #f)(client-fill-cell-node-values 'velocity-magnitude 1)*cx-render/cell/max*

(dpm-compute-pathlines '(injection-0) "Velocity Magnitude" "null" "null" "null" "null" 1 #f "none" "" "" -1 -1 #t 3 #f #f #f)()

 

Error: wta(1st) to string_length

 

Error Object: 1

 

 

rwoolhou posted this 17 June 2019

Can you check in the TUI that you have particles in the domain? 

Tareq posted this 17 June 2019

Yes I checked there are particles in the domain it written its tracked and I can visualize them by particle track but i cannot make the animation, each time i make i receive this error

rwoolhou posted this 18 June 2019

Are the particles being tracked steady or transient? It's not a function I ever use but I can see it'll struggle to plot the full track (steady) each time, but should track the position (transient) OK. 

Tareq posted this 19 June 2019

The program running in the transient, and if you make the animation tracking for contour it will be ok, but once made for particles track it gave this error! please, I did not get your point " It's not a function I ever use but I can see it'll struggle to plot the full track "   

Best Regards,

Tareq

  

rwoolhou posted this 19 June 2019

OK, for a particle track in steady you get a line showing the full trajectory. I can see that not working well with the animate tool. 

If you display particles as you have in the Particle Tracks panel manually what happens?

Tareq posted this 21 June 2019

if i work manually it works perfect, like run for some steps after display particles it works, but if it made in animation I received this error

rwoolhou posted this 24 June 2019

Can you re-create the particle animation now the model is running?  I wonder if it fails because there are no particles to start with. As an aside, why are you plotting the flow velocity on the particles and not the particle velocity?

Close