Persistent Negative Cell Volume Error

  • 52 Views
  • Last Post 07 June 2019
aCVP posted this 05 June 2019

Hi all - I am completing a dynamic mesh simulation with a mesh that moves node by node. The simulation works for an incredibly coarse mesh, but anything finer will give the "negative cell volume" error. For accuracy, I need a finer mesh. I have tried using a smaller time step, but I still get the error.

Any ideas? I have been making mesh after mesh after mesh trying to get something to work without any luck. Is there any way to have a very coarse mesh but it still be accurate?

Order By: Standard | Newest | Votes
rwoolhou posted this 05 June 2019

Check the amount of motion relative to the cell size: then make sure your time step is small enough that you don't remove a whole cell in one step. Given the error you should be able to test this with the preview tools so it should be fairly quick to figure out the step size. 

aCVP posted this 05 June 2019

The amount of motion is about half of the cell size. It is only two or three cells that are giving the error. Using meshing, How can I locate these cells with negative volume and then correct their skewness prior to running the simulation?

rwoolhou posted this 05 June 2019

If they're negative volume before the model starts have a look for highly skew elements in the meshing tool. 

aCVP posted this 05 June 2019

There are not any negative cells before the model starts, but the highest skewness is around 0.89. Using the meshing tool, I can locate these elements, but it will not let me select them to refine them.

When using the "select element" tool, it only selects the element on the surface (not internal) and does not give me an option to select the elements on the inside. How can I do this? Is there a way to automatically select and refine internal elements with skewness above a certain point?

aCVP posted this 06 June 2019

To provide a bit more insight into the problem:

  • I am using approximately 1.1 million elements
  • According to "Mesh Scale Info" in Setup/Remeshing, the min length scale is 0.279mm
  • When changing movement per timestep (i.e. by changing timestep size) to 0.15mm, I get negative cell volume
  • When changing movement per timestep (i.e. by changing timestep size) to 0.03mm, I get negative cell volume
  • Min orthogonal quality is >0.10  (around 0.12) and max skewness is <0.9 (around 0.86) at the beginning of the simulation
  • Nodal displacement occurs via UDF using grid motion

If I am performing displacements that are less than the min length scale, why am I getting negative cell volume? Is there a way to correct this in the remeshing tab? All adjacent boundaries are set as deformable with smoothing/remeshing applied.

 

rwoolhou posted this 06 June 2019

Can you post images of the problem areas? 

  • Liked by
  • aCVP
aCVP posted this 06 June 2019

I'm not sure how helpful this is, but here is an image of the elements that have the highest skewness prior to running the simulation. 

With that said, is there a way to visualize and isolate the negative cell volume AFTER previewing the mesh motion? I am having trouble doing this and it would be much easier to diagnose the problem if I could find the specific cells.  

Another observation: I have told "remeshing" to keep the min length scale above 0.26mm. However, this is not working. It seems like remeshing is ignoring what I am telling it? Min length scale is dropping below 0.14mm. Is there a way to force the "remeshing" function to keep the min length scale above 0.26?

rwoolhou posted this 06 June 2019

Check the number & size of cells in the regions you've got poor cells. If that gap is small you'll have problems. 

  • Liked by
  • aCVP
aCVP posted this 07 June 2019

The gap size doesn't appear too small. Perhaps it is my remeshing parameters that are wrong?

Under the "Dynamic Mesh" tab, I have enabled Smoothing (default parameters) and Remeshing. Under the remeshing tab, I have checked "Local Cell," "Local Face," and "Region Face." Furthermore, I changed the "Parameters" in Remeshing to "Use Defaults."

I then created dynamic mesh zones for each inlet/outlet and the fluid zone. I did not create a dynamic mesh zone for the "interior" object. Each zone is set to "Deforming" and the parameters are copied from the "Zone Scale Info" box.

Finally, the "wall" object is set to a user-defined function and "deform adjacent boundaries" is checked.

What is confusing to me is that for min. scale length, the reported and entered values are no less than 0.26. My greatest displacement per timestep is 0.15 mm. However, when I get the "negative cell volume" error and check the min length, it is 0.14mm. It appears as though remeshing is not doing its job (though I suspect this is because I have an incorrect setup).

Please let me know if you can think of any solutions! I appreciate it!

rwoolhou posted this 07 June 2019

Not sure: can you check your set up against one of the tutorials to confirm you've not missed an option.  Very difficult to diagnose without the files, and we're not able to do that at the moment due to the rules of staff working on here. 

  • Liked by
  • aCVP
aCVP posted this 07 June 2019

I'll see what I can do - if I can find a solution, I will post it here!

Close