Polyflow Dimension fault; working array not large enough

  • 79 Views
  • Last Post 22 August 2019
lbskw posted this 08 August 2019

Hello everyone,

I'm working on a Simulation with Ansys Polyflow,

I'm getting the following error when I try to "save and exit" the problem set up:

Dimension fault: a local working array is not large enough ! Please, set value of parameter MAXDAT (datafile.com) to 1987 at least. (error code #4 detected)

The solution to this problem may be easy, but I could not find anywhere where I could input this MAXDAT as a parameter,

Has anyone experimented this before and know how to fix this?

Thanks in advance!

Attached Files

Order By: Standard | Newest | Votes
rwoolhou posted this 08 August 2019

Can you check how cells you have? There's a cap on Mechanical (32k) and Fluent/CFX (512k) cell counts for ANSYS Student & Teaching licences: I don't know what Polyflow caps at, or when/how it checks. 

lbskw posted this 08 August 2019

Thank you for your answer.

I have more than 1kk cells. But this is not the problem, because Polyflow caps only when using the solver, not in the steps before.

Besides that, i have the same issue when I tried using the in the University computer labs, which have the Full Ansys version (Not capped)

I think it should be some configuration in the (Polydata, Polymat), but I can't find it

rwoolhou posted this 08 August 2019

The Computer labs most likely have Teaching keys rather than the full version. Work through the steps again and look for whatever is missing. 

lbskw posted this 11 August 2019

Hi, 

thank you for your answer again,

I just take some time to confirm what you written,

1. In the Student version I have at home, Polyflow caps for meshes bigger than 100k cells. If the mesh is bigger than 100k, Workbench allows me to mesh, to do all the Set Up in Polyflow and only when I run the solver that it caps. It informs in a message that the mesh exceeds the limit of the version. 

2. I went to the University and confirmed that they have full version in a specific lab, in which I performed again all the same steps. In this lab they run very large problems without any limitation. For my solution described above, I receive the same error message. This error message appears when I try to save the Set Up file. In other words, I even can't run the solver because no file is saved.

This indicates that the problem is not the software version. 

The geometry I'm simulating, if I cut it to a quarter in size, can ben saved in Polyflow without the error message (400k elements), and run in the solver. On the other hand, the entire geometry can't be saved, with the above mentioned error,

So the question would be if this parameter MAXDAT can be put somewhere

Below I'm sending two images. The first shows the message when using a capped version. The second I don't know if helps, but shows the version running in the University.

1. The Student version Error (Version limit)

1 - Student Version

 

2. The University Version

 

University Version

 

 

abenhadj posted this 12 August 2019

Are you using Teaching License or Full Research License? Please let your IT /System Admin check that for you (University)

Best regards,

Amine

abenhadj posted this 12 August 2019

On Windows you can to %tmp% then the folder .ansys and here you will find a plnety of *.out files. check the one related to POLYFLOW and check which increments have been used.

Best regards,

Amine

lbskw posted this 13 August 2019

Hi Amine,

Thank you for your answer,

The University version is Full Research License at the specific lab I use. I tested it now with my Student Version at home.

I just checked the temp folder. There is none *.out files. And maybe because the solver hasn't run yet? The error message appears when I save the Set Up. This is the step before the solver is Run.

The files that are in the folder are the following:

files

 

tsiriaks posted this 13 August 2019

Hi lbskw,

You have to check inside these files but let me provide an easier way to check licensing for you.

Please post the output of the following command

Windows

"%awp_root193%\..\Shared Files\Licensing\winx64\ansysli_util" -checkout POLYFLOW

Linux

/ansys_inc/shared_files/licensing/linx64/ansysli_util -checkout POLYFLOW

Thanks,

Win

lbskw posted this 19 August 2019

Hi tsiriaks,

 

The version where I'm running the workbench is: Ansys Academic Research Mechanical and CFD. 

 

Version

tsiriaks posted this 19 August 2019

Hi lbskw,

Thank you for the info.

So, you are really using aa_r (Full academic research license).

To me, this seems good. Let's wait to see what Rob, Amine have to say about this.

Thanks,

Win

lbskw posted this 21 August 2019

Thank you for your answer tsiriaks,

Hope we can find a fix for this,

 

rwoolhou posted this 21 August 2019

Can you check if there are any memory/stack/heap options in the launch command?  I don't use Polyflow, but Fluent used to have issues with many boundary labels in v6 & R12 but that's gradually gone away as the defaults have been increased as the hardware has improved. 

lbskw posted this 21 August 2019

Hi rwoolhou,

there must be, but i have no idea where to find it (using Windows here)

Before i posted this topic, I went through all folders in the Polyflow folder and I found nothing useful,

There is this .p3rc where maybe something could be written, but everything I tried had no effect,

p3rc

 

I'm convinced the software is limiting the geometry, not the computer hardware,

I just created the entire geometry manually using SpaceClaim, to have all being just one surface. With this approach, the problem disappeared and I could save the Set Up file. But this is no solution because:

   The geometry created in Spaceclaim to be one surface must be attached to a plane. This leads to a mesh with 1,5 million elements (2,1 fold increase)

   The imported geometry had much less surface area, with 688 thousand elements. On other hand, it has more surfaces, and then the problem appears.

To summarize, the number of surfaces are being limited by the software, and is problably what the "MaxDat" parameter handles

rwoolhou posted this 21 August 2019

Are there any moving bodies? If so check the limitations. I've asked a colleague to have a look, but not sure if he's in today. 

lbskw posted this 21 August 2019

Hi,

Thank you for your answer

The are 3 Subdomains,

One is a Mould that moves up in the beginning of the process, until it touches the membrane. Is not a moving body, but a moving surface.

Could you please inform me where may I check the limitations? I could not find any

 

 

 

rwoolhou posted this 21 August 2019

It's in the Documentation, think I was looking in the section on how to start Polydata.  

lbskw posted this 22 August 2019

Hi rwoolhou,

Could you please be more specific?

In the document I have I couldn't find any relevant limitation related to this problem,

Thanks in advance,

Close