Problem of simulating pipe flow with 2D axisymmetric using Fluent

  • 47 Views
  • Last Post 05 June 2020
  • Topic Is Solved
AlexC posted this 01 June 2020

I have a problem with simulating pipe flow with 2D axis symmetric using Fluent. 

I was able to solve the problem without any problem when I create the geometry using "DesignModeler" that comes with Ansys. Yet when I create 2D geometry in Solidworks and import it to Ansys, I wasn't able to solve it. 

When I do Hybrid Initialization, the error message is:

Error: floating point exception

 

Error Object: #f

 

If I do Standard Initialization, I can run the simulation, yet it never converges like below:

 

I don't know why I got this problem when importing the 2D geometry from Solidworks file. I'm pretty sure the 2D file created in Solidworks is fine. Because if I don't use axisymmetric and use "Planar" and set the axis line as "wall" boundary condition, then Fluent can still solve it. 

 

You can find my files here in this link:

https://drive.google.com/drive/folders/1p-Tktyi_0oLmxnqu_6SsNcFv5O93FoHK?usp=sharing

 

Thank you.

 

Alex

 

Order By: Standard | Newest | Votes
Kalyan Goparaju posted this 01 June 2020

Hello Alex, 

Unfortunately, we won't be able to review the files. 

Can you please check scale of the model that you are exporting from Solidworks? 

Thanks, 

Kalyan

AlexC posted this 01 June 2020

Hello Kalyan,

 

The model is 0.5mm*10mm rectangular 2D geometry. I don't understand why you want to check the scale. I didn't see any problem with that. Because I can use the same geometry and run successfully as long as I don't use axis symmetry. Yet as I said in the beginning, I can generate the geometry in Ansys DesignModeler and ran successfully when using axis symmetry. 

You won't be able to review the files because I didn't share it in the right way? I don't know how I can pass the question to you in a more clearer way. Probably you have some better suggestion. 

Thank you.

Alex

Kalyan Goparaju posted this 02 June 2020

Hello Alex, 

The reason I wanted to check the scale of the model in Fluent is to make sure it wasn't, by accident, scaled to different units when exported from SW and imported into Fluent. As a rule, we can only provide guidance and help debug problems. We are restricted from downloading files and working on them.

Can you please share screenshots of your setup? Turbulence model, boundary conditions, Methods etc?

Thanks,

Kalyan

AlexC posted this 02 June 2020

Hey Kalyan,

Thank you for reminding me the rule. I understand that. I redid this case, and took screenshots for each step as below:

1. SolidWorks 2D file. It's saved as ".SLDPRT" format. 

Dimension: 0.5 mm*10 mm.

Unit system: MMGS.

 

 

2. Drag Fluid Flow (Fluent) to the Workbench project space. 

3. Import the SolidWorks file into Ansys. See screenshot below. 

  • I opened the geometry in Ansys DesignModeler. 
  • Right Click Import1, and click Generate. 
  • Units make sense. No problem observed. 

 

4. Mesh. See screenshot below.  (Mesh should not be a problem since I'm using laminar flow as an example here. )

5. Setup. 2D with double precision. 

After I opened the Fluent solved, I got the following warning message. (This is not a problem since when I click "Axisymmetric", this error will be gone)

  • Warning: The use of axis boundary conditions is not appropriate for a 2D/3D flow problem. Please consider changing the zone type to symmetry or wall, or the problem to axisymmetric.

 

Then under General, I click Check, and below are the messages in Console:

 

 

Then I click Report Quality and get the following:

  • Mesh Quality:
  • Minimum Orthogonal Quality = 1.00000e+00 cell 2000 on zone 4 (ID: 2001 on partition: 0) at location ( 4.97354e-04 9.95000e-03)
  • (To improve Orthogonal quality , use "Inverse Orthogonal Quality" in Fluent Meshing,
  • where Inverse Orthogonal Quality = 1 - Orthogonal Quality)
  • Maximum Aspect Ratio = 1.89227e+01 cell 2002 on zone 4 (ID: 2003 on partition: 0) at location ( 4.97354e-04 9.85000e-03)

 

Then I clicked "Axisymmetric" since I want to simulate the pipe flow. 

 

6.Laminar flow model. (air velocity 1m/s, Re<100)

I didn't change anything in Materials and CellZone. I'm using air as fluid by default. 

 

7. Boundary condition. 

axis: axis

inlet: velocity-inlet. I set 1 m/s.   Re is about 50

outlet: pressure-outlet. 

wall: wall

 

8. I didn't change anything in Methods. Everything is default. 

 

9. Initialization.

Hybrid Initialization.

After I click Initialize, I got the following error message. (It's weird because I don't have this problem if I create the geometry in Ansys DesignModeler)

 

 

10. If I try Standard Initialization as below, nothing pops up when I click Initialize. Then I can run the calculation without problem. It converges pretty quickly. (Tolerance is set to 1e-6)

 

11. However, after I open CFD-post, the geometry changed! I've no idea what happened here. 

 

 

----------------------------------------------------------------------

Please advise. 

 

Thank you.

Alex

Kalyan Goparaju posted this 03 June 2020

Hello Alex, 

I think I understand what's going on. In Fluent 2D, the 'axis' of the problem has to always be the x-axis. For your case, you need to flip the model such that the longer side is parallel to x-axis. Can you please try this out and let me know if it works? 

Thanks,

Kalyan

  • Liked by
  • AlexC
AlexC posted this 03 June 2020

Hello Kalyan,

Awosome! This solved the problem. 

But a following question. Does the feature that Fluent 2D uses x-axis as the symmetric axis only applies when I import the geometry from Solidworks? Because as I said before, I created the same geometry using Ansys DesignModeler (with y-axis as the symmetric axis), and there is no problem. 

Thank you. 

Alex

Kalyan Goparaju posted this 05 June 2020

Hello Alex, 

No, this applies to any model. I am wondering if the model got automatically flipped, but I am not sure. 

Thanks, 

Kalyan

  • Liked by
  • AlexC
AlexC posted this 05 June 2020

Got that. Thank you Kalyan!

 

Alex

Close