Problem with ANSYS 18.2 SpaceClaim

  • 684 Views
  • Last Post 5 weeks ago
rangushiva posted this 09 October 2018

I have downloaded "ANSYS 18.2 (3.9 GB) Student version" to learn ANSYS by online course started by Edx but unfortunately I wasn't able to open the geometry. Every time I open it I get the error "Geometry editor was closed abnormally" . 

Attached Files

Order By: Standard | Newest | Votes
kkanade posted this 09 October 2018

Please check if you have read write permissions to respective folders. 

Please run set up with 'Run as Administrator'. 

Regards,

Keyur

 

rangushiva posted this 09 October 2018

Yes, i run set up with 'Run as Administrator' but no use, same error displayed. Please help me what i need to do?

tsiriaks posted this 09 October 2018

Hi rangushiva ,

Let's narrow down the issue. Can you open up stand-alone Spaceclaim (SCDM 18.2) ?

If so, this is a configuration issue between Workbench and SpaceClaim, most likely with Windows registry.

If not, this is very likely a graphics issue. Type 'dxdiag' (without quote) in your Windows search or in CMD Prompt , then enter. This will bring up the DirectX Diagnostic Tool, wait until it finishes loading then click on all 'Display #' tabs (depending on how many monitors you are using) and take screenshot of each of this 'Display #' tab and post them here.

Thank you,

Win

 

rangushiva posted this 10 October 2018

Yes, i can open stand-alone Spaceclaim (SDCM 18.2) and i can design in it but the problem is that when opening it through Workbench the error message is displayed and cannot attach a geometry to workbench, so i think exactly problem is because of configuration issue between Workbench and SpaceClaim. I am using a external NVIDIA GEFORCE GT 710 (2GB) graphics card, 3 GB RAM and OS with windows 7 (64 bit). Please help me any one in resolving this issue as soon as possible.

Thanks in advance.

tsiriaks posted this 10 October 2018

Hi rangushiva ,

Thanks for the info.

In that case, no need to worry about graphics at this time. Try the following potential resolutions in this order (Note: Make sure there is no ANSYS products running while performing these workarounds)

 

Resolution # 1 : Reset configurations

Rename

C:\Users\<username>\AppData\Local\SpaceClaim

C:\Users\<username>\AppData\Roaming\SpaceClaim

to anything else

 

Resolution # 2 : Run Product & CAD Configuration v18.2 with 'run as admin' > Configure Products & CADs > Select all and click Next

Then, run the CAD Configuration Manager 182 with 'run as admin' > check the box for SpaceClaim Direct Modeler > Click Next, then click Configure Selected CAD Interfaces, and make sure you see 'success'

 

Resolution # 3 : Check if this registry is created after the CAD Config was run

Open regedit, then go to this key HKEY_CLASSES_ROOT\SpaceClaim.AnsysSCDM.182 and make sure it exists with correct Path value (e.g., C:\Program Files\ANSYS Inc\ANSYS Student\v182\scdm)

If not, it means your user account doesn’t have rights to change the registry, please ask IT admin to run CAD Config with full admin rights. Sometimes, this can also be caused by some Anti-virus software preventing you from modifying Windows registry.

 

Hope this helps.

Thank you,

Win

  • Liked by
  • rangushiva
rangushiva posted this 11 October 2018

Hello tsiriaks,

Thanks for your reply and suggestions.

I tried your first resolution but it didn't worked for me and second one is based on CAD Configuration Manager, so i am using student version of Ansys 18.2 it doesn't come with CAD Configuration Manager. The third resolution is about registry path of Spaceclaim and it is in correct path. So, the above methods didn't worked for me.

Please give me a solution for it and i am struggling with it from 1 week.

Thank you.

rwoolhou posted this 11 October 2018

If you can open stand alone do that and then use the Workbench icon to transfer into WB. Connect a mesh cell up to that and it should all work. Short term it'll make editting models more difficult but it'll mean you can learn the tool and meshing.

Can you check where WB is trying to write scratch files ( Tools -> Options -> Project Management) and that you have write permissions there.

tsiriaks posted this 11 October 2018

Hi rangushiva,

You have that for student version too (at least for 19.1, not sure if it's different in 18.2)

Product & CAD Configuration 19.1

"C:\Program Files\ANSYS Inc\ANSYS Student\v191\ProductConfig.exe"

CAD Configuration Manager 19.1

"C:\Program Files\ANSYS Inc\ANSYS Student\v191\commonfiles\CAD\bin\winx64\Ans.CadInt.CADConfigUtilityGUI.exe"

Try resolution #2 , then post a full screenshot of this key HKEY_CLASSES_ROOT\SpaceClaim.AnsysSCDM.182

In the meantime, you can follow the workaround mentioned above to work on it.

Thank you,

Win

rangushiva posted this 16 October 2018

Thanks for all your replies and suggestions regarding my problem.

My problem resolved myself. I changed all the settings in Workbench and Spaceclaim that are related to geometry, so that solved my problem and now iam happy that it is working fine.

Thank you.

----Shiva

  • Liked by
  • Zion
tsiriaks posted this 16 October 2018

Hi Shiva,

That's good news. Thank you for the update.

Win

deepakpushpad posted this 02 November 2018

hi raghu.

will you describe how you resolve this issue. actually i am facing this issue right now. i am using ansys 19.0 with my msi gt 710  2gb graphics card

tsiriaks posted this 02 November 2018

Hi deepakpushpad,

Have you tried all of the resolutions that I listed above ?

Do you have exact same issue (can launch stand-alone but not from Workbench) ?

Thank you,

Win

Zion posted this 17 January 2019

Please how did you change the settings in the Workbench and Spaceclaim that are related to geometry? Because am currently facing similar issues relating to  "Geometry editor was closed abnormally" .

Kindly assist me. Thank you\

Regards

Zion

Zion posted this 17 January 2019

Please how did you change the settings in the Workbench and Spaceclaim that are related to geometry? Because am currently facing similar issues relating to  "Geometry editor was closed abnormally" .

 

Kindly assist me. Thank you\

 

Regards

 

Zion

tsiriaks posted this 17 January 2019

Do you have exact same issue (can launch stand-alone but not from Workbench) ?

If so, try resolutions I listed above

Thanks,

Win

niveshk posted this 5 weeks ago

Hi,
I"m facing the exact same issue, and I've tried all the above mentioned resolutions, but did not work. I still keep getting "Geometry editor was closed abnormally" error. I'm able to open spaceclaim from my workbench itself though. But I'm not able to import the geometry into "Mechanical"

Here are the logs that I found:
System.Exception: Unable to attach to geometry file E:\Nivesh\ANSYS Projetcs\2D-Conduction-edx\Design2.scdoc. Unable to attach geometry.at Ansys.Simulation.Core.Commands.RefreshModel.ExecuteCommand(IFullContext context)at Ansys.Addins.Infrastructure.CommandUtilities.CommandHelper.Execute(IFullContext context)at Ansys.Core.Commands.Concurrency.CommandWorkUnit.executeInContext(CommandContext subContext, IExecutionEngineCallback tracer)at Ansys.Core.Commands.Concurrency.BaseWorkUnit.doExecute(IExecutionEngineCallback executionEngine, CommandContext subContext)at Ansys.Core.Commands.Concurrency.BaseWorkUnit.Execute(IExecutionEngineCallback executionEngine, Boolean dontCatchExceptions)--- Ansys.Core.Commands.CommandFailedException: Unable to attach to geometry file E:\Nivesh\ANSYS Projetcs\2D-Conduction-edx\Design2.scdoc. Unable to attach geometry.CommandName: Mechanical.RefreshModel(Container="Model", RemainingContainers=[])at Ansys.Core.Commands.CommandAsyncResult.RethrowFailureException(Exception e)at Ansys.Core.Commands.CommandAsyncResult.Wait(Int32 milliSecondsTimeout, Boolean exitContext)at Ansys.ProjectSchematic.Commands.RefreshCommand.RefreshComponents(IFullContext context, IEnumerable`1 componentsToRefresh, Boolean refreshUnfulfilled)at Ansys.Core.Commands.Concurrency.CommandWorkUnit.executeInContext(CommandContext subContext, IExecutionEngineCallback tracer)at Ansys.Core.Commands.Concurrency.BaseWorkUnit.doExecute(IExecutionEngineCallback executionEngine, CommandContext subContext)at Ansys.Core.Commands.Concurrency.BaseWorkUnit.Execute(IExecutionEngineCallback executionEngine, Boolean dontCatchExceptions)--- Ansys.Core.Commands.CommandFailedException: Unable to attach to geometry file E:\Nivesh\ANSYS Projetcs\2D-Conduction-edx\Design2.scdoc. Unable to attach geometry.CommandName: RefreshComponent(Component="/Schematic/Component:Model")at Ansys.Core.Commands.CommandAsyncResult.RethrowFailureException(Exception e)at Ansys.Core.Commands.CommandAsyncResult.Wait(Int32 milliSecondsTimeout, Boolean exitContext)at Ansys.ProjectSchematic.Commands.RefreshComponentCommand.InvokeAndWait(IProtectedContext context, DataReference Component)at Ansys.Simulation.GUI.EditModelBase.InvokeEditModelOperation(GuiOperationContext context, IGuiOperation guiOperation, DataContainerReference dcr)at Ansys.UI.GuiOperationContext.Invoke(GuiOperationMetaData operationData)at Ansys.UI.UIManager.InvokeOperationCore(String pseudoname, OperationDelegate callback, Boolean allowOSMessages, Boolean coreTransaction, Boolean deferredRefreshOnly)

Thanks

niveshk posted this 5 weeks ago

Update :
When I import geometry from soldworks (.igs) files it works well. Not sure what the issue is with SpaceClaim Geometry editor.

tsiriaks posted this 5 weeks ago

If you can open a blank SpaceClaim from Workbench, then you are having a different issue.  Please create a new thread.

Try importing your geometry from a simple directory like C:\Temp 

Also, try a different geometry file created by SpaceClaim. You can launch stand-alone SpaceClaim, create some simple geometry then save it in scdoc. 

Close