Problem with ANSYS 18.2 SpaceClaim

  • 264 Views
  • Last Post 02 November 2018
rangushiva posted this 09 October 2018

I have downloaded "ANSYS 18.2 (3.9 GB) Student version" to learn ANSYS by online course started by Edx but unfortunately I wasn't able to open the geometry. Every time I open it I get the error "Geometry editor was closed abnormally" . 

Attached Files

Order By: Standard | Newest | Votes
kkanade posted this 09 October 2018

Please check if you have read write permissions to respective folders. 

Please run set up with 'Run as Administrator'. 

Regards,

Keyur

 

rangushiva posted this 09 October 2018

Yes, i run set up with 'Run as Administrator' but no use, same error displayed. Please help me what i need to do?

tsiriaks posted this 09 October 2018

Hi rangushiva ,

Let's narrow down the issue. Can you open up stand-alone Spaceclaim (SCDM 18.2) ?

If so, this is a configuration issue between Workbench and SpaceClaim, most likely with Windows registry.

If not, this is very likely a graphics issue. Type 'dxdiag' (without quote) in your Windows search or in CMD Prompt , then enter. This will bring up the DirectX Diagnostic Tool, wait until it finishes loading then click on all 'Display #' tabs (depending on how many monitors you are using) and take screenshot of each of this 'Display #' tab and post them here.

Thank you,

Win

 

rangushiva posted this 10 October 2018

Yes, i can open stand-alone Spaceclaim (SDCM 18.2) and i can design in it but the problem is that when opening it through Workbench the error message is displayed and cannot attach a geometry to workbench, so i think exactly problem is because of configuration issue between Workbench and SpaceClaim. I am using a external NVIDIA GEFORCE GT 710 (2GB) graphics card, 3 GB RAM and OS with windows 7 (64 bit). Please help me any one in resolving this issue as soon as possible.

Thanks in advance.

tsiriaks posted this 10 October 2018

Hi rangushiva ,

Thanks for the info.

In that case, no need to worry about graphics at this time. Try the following potential resolutions in this order (Note: Make sure there is no ANSYS products running while performing these workarounds)

 

Resolution # 1 : Reset configurations

Rename

C:\Users\<username>\AppData\Local\SpaceClaim

C:\Users\<username>\AppData\Roaming\SpaceClaim

to anything else

 

Resolution # 2 : Run Product & CAD Configuration v18.2 with 'run as admin' > Configure Products & CADs > Select all and click Next

Then, run the CAD Configuration Manager 182 with 'run as admin' > check the box for SpaceClaim Direct Modeler > Click Next, then click Configure Selected CAD Interfaces, and make sure you see 'success'

 

Resolution # 3 : Check if this registry is created after the CAD Config was run

Open regedit, then go to this key HKEY_CLASSES_ROOT\SpaceClaim.AnsysSCDM.182 and make sure it exists with correct Path value (e.g., C:\Program Files\ANSYS Inc\ANSYS Student\v182\scdm)

If not, it means your user account doesn’t have rights to change the registry, please ask IT admin to run CAD Config with full admin rights. Sometimes, this can also be caused by some Anti-virus software preventing you from modifying Windows registry.

 

Hope this helps.

Thank you,

Win

  • Liked by
  • rangushiva
rangushiva posted this 11 October 2018

Hello tsiriaks,

Thanks for your reply and suggestions.

I tried your first resolution but it didn't worked for me and second one is based on CAD Configuration Manager, so i am using student version of Ansys 18.2 it doesn't come with CAD Configuration Manager. The third resolution is about registry path of Spaceclaim and it is in correct path. So, the above methods didn't worked for me.

Please give me a solution for it and i am struggling with it from 1 week.

Thank you.

rwoolhou posted this 11 October 2018

If you can open stand alone do that and then use the Workbench icon to transfer into WB. Connect a mesh cell up to that and it should all work. Short term it'll make editting models more difficult but it'll mean you can learn the tool and meshing.

Can you check where WB is trying to write scratch files ( Tools -> Options -> Project Management) and that you have write permissions there.

tsiriaks posted this 11 October 2018

Hi rangushiva,

You have that for student version too (at least for 19.1, not sure if it's different in 18.2)

Product & CAD Configuration 19.1

"C:\Program Files\ANSYS Inc\ANSYS Student\v191\ProductConfig.exe"

CAD Configuration Manager 19.1

"C:\Program Files\ANSYS Inc\ANSYS Student\v191\commonfiles\CAD\bin\winx64\Ans.CadInt.CADConfigUtilityGUI.exe"

Try resolution #2 , then post a full screenshot of this key HKEY_CLASSES_ROOT\SpaceClaim.AnsysSCDM.182

In the meantime, you can follow the workaround mentioned above to work on it.

Thank you,

Win

rangushiva posted this 16 October 2018

Thanks for all your replies and suggestions regarding my problem.

My problem resolved myself. I changed all the settings in Workbench and Spaceclaim that are related to geometry, so that solved my problem and now iam happy that it is working fine.

Thank you.

----Shiva

tsiriaks posted this 16 October 2018

Hi Shiva,

That's good news. Thank you for the update.

Win

deepakpushpad posted this 02 November 2018

hi raghu.

will you describe how you resolve this issue. actually i am facing this issue right now. i am using ansys 19.0 with my msi gt 710  2gb graphics card

tsiriaks posted this 02 November 2018

Hi deepakpushpad,

Have you tried all of the resolutions that I listed above ?

Do you have exact same issue (can launch stand-alone but not from Workbench) ?

Thank you,

Win

Close